yes there are important error and omissions

this is a very good book
The sidebar, context explanation made it clear

Thank you,
Douglas
Free! node.js and javascript ide

works on windows, linux, mac

https://code.visualstudio.com/
you should put up some links
Camtasia would be a great addition to your toolbox.

open source software:
http://sourceforge.net/directory/audio-video/video/vidcapture/os:windows/freshness:recently-updated/
notepad - copy paste modify and copy into terminal

or

notepad mongoimport

copy paste and modify contents

the readme doesn't have:

git clone -b chapter-03 https://github.com/simonholmes/getting-MEAN.git
Mongoose connected to mongodb://localhost/loc8r (copied from terminal)

Getting single review

{ _id: 55d6177d210bd39489580e5c,
name: 'Starcups',

reviews:
[ { author: 'Simon Holmes',
id: 55d619c7210bd39489580e60,
rating: 5,
timestamp: Tue Jul 16 2013 00:00:00 GMT-0400 (Eastern Daylight Time),
reviewText: 'What a great place. I can\'t say enough good things about it.',
createdOn: Sat Aug 22 2015 13:24:17 GMT-0400 (Eastern Daylight Time) } ] }

GET /api/locations/55d6177d210bd39489580e5c/reviews/55d619c7210bd39489580e60 404

postman says: "locationid not found" ? it just printed in the console and was lost

there isn't an id in the model

What finally worked for me was:

in reviews.js changed: review = location.reviews.id(req.params.reviewid);

to

review = location.reviews;

and got the correct output

{"location":{"name":"Burger King","id":"55d61a51210bd39489580e62"},"review":[{"author":"Simon Holmes","id":"55d61a51210bd39489580e62","rating":5,"timestamp":"2013-07-16T04:00:00.000Z","reviewText":"What a great place. I can't say enough good things about it.","createdOn":"2015-08-23T12:23:46.691Z"}]}
Listing 6.1 Routes defined in .... ends in /locations.js
should be index.js



disregard
under
extends layout

the underscore doesn't print here or any where else as in

_includes/sharedHTMLfunctions
also in following pages
pdf page 115 v12

under 4.5.1 heading

We're 30.80going to start...

last sentence has "list.jade" --- should be locations-list.jade
I stand to be corrected.

The download code ran perfectly and showed the map

why the cut and pasted URL I tried in the url didn't work is beyond me?

My Bad
Douglas
gem install foreman

then foreman start

heroku foreman is not a heroku command
will sessions, authentication, and authorization be amended to existing code ?
At bottom of page

pdf Reads - In listing 10.27....

the Listing shown - is Listing 10.14
To attract a large number of readers, html is a better choice than jade
Hands Down!

jade can scare people away, limiting the readership

For instance, a space in a jade template kept it from displaying!
tracking the space down was wasted and a needlessly frustrating time.

For the virtuoso, jade is probably a good choice, but the larger readership
probably are not virtuoso's.

handlebars is more friendly and intuitive view engine, operates in a html environment.

just a thought

Thank you,
Douglas
adding $locationProvider.html5Mode(true)

to app_client/app.js did not work

to make it work I went into (index.html) and into the head section
and entered < base href="/" >

after the entry it works

also the hash was left out of previous href entries #/somepage
5 Missing Underscores, this occurs through out the book

var appClientFiles = [

app client , should be app_client
using git -b chapter-10 -- No Locations Found --
=========== cmd =============================

GET /favicon.ico 200 2.946 ms - 891
GET /common/directives/navigation/navigation.template.html 200 1.580 ms - 554
GET /common/directives/pageHeader/pageHeader.template.html 200 1.163 ms - 211
GET /common/directives/ratingStars/ratingStars.template.html 200 1.661 ms - 405
GET /common/directives/footerGeneric/footerGeneric.template.html 200 2.904 ms - 124
Geo Results []
Geo stats { nscanned: 8,
objectsLoaded: 8,
avgDistance: NaN,
maxDistance: 0,
time: 0 }
GET /api/locations?lng=-81.7328567&lat=28.022243500000002&maxDistance=20 200 7.754 ms - 2
=======================================================================
code from git
=======================================================================

loc8rData.$inject = ['$http'];
function loc8rData ($http) {
var locationByCoords = function (lat, lng) {
return $http.get('/api/locations?lng=' + lng + '&lat=' + lat + '&maxDistance=20');
};
====================================================================
There are wifi areas much less than 20 km/miles
Thank you,
Douglas
also the underscore for id is not being printed in the pdf

pdf: id instead of _id.
pdf page 270

input#filter(type="text", name="filter", ng-model="textFilter")

using chrome v43, windows 8

can't type into textbox

tried a z-index setting,

I went into the style.css and entered body{ color: black;}
now I have a cursor and visible type

how did the color become white, is this something in amelia-bootstrap?



Thank you,
Douglas
erlang is fast
pdf page 233

Note that at this stage in the development we don’t have an authentication method in place,
so we have no concept of individual users. We’ll add this in right at the end of the book when
all of the application functionality is in place.

this book has all the basis covered
Error trapping is Great one stop coding , with nodemon,mongoose,browser opened giving us immediate feedback.
what to test for is where experience comes in to do this timely and this book gives that guidance

for automated testing there is a firefox plugin that writes code from your interactions with a gui
connected to your application. A piece of cake.

1) - with firefox open browse to
2) - http://docs.seleniumhq.org/download/
3)- scroll down page to Selenium IDE version 2.9.0 enjoy
Thank you for the correct answer,
Douglas
After reading most of the mongoose pdf, I googled Simon Holmes for books
You are a very Good author, I'm enjoying the book

pdf page 185

-------This code does not Work------ (followed by code block that works)
--------------------------------------------------------------
if (location.reviews && location.reviews.length > 0) { #C
review = location.reviews.id(req.params.reviewid); #D
if (!review) { #E
sendJsonResponse(res, 404, { #E
"message": "reviewid not found" #E
}); #E
} else { #F
response
-----------------------------------------------------------------------
-----to make the code work I made a pure guess and it worked--------
-----------------------------------------------------------------------
if (location.reviews && location.reviews.length > 0) {
var myid = req.params.reviewid;
review = location.reviews + myid;
if (!review) {
sendJsonResponse(res, 404, {
"message" : "reviewid not found"
});
} else {
-----------------------------------------------------------------------
windows 8
Emacs has nice support for elixir and iex.
Which makes for a pleasant elixir ide
iex should be in system path

I'm enjoying the book
the links don't work
very nice book so far.
I'm enjoying your book
Let's hope you write more books
I bought many many manning books and
the links always worked, I guess it depends on
who they assign to your manifest
I just opened Elixir in Action Meap in my Adobe Acrobat 9, (old version)

I opened page 17

In about 20 seconds I created a functional link for Footnote 1 -- http://erlang.org/
In another 20 seconds I created a functional link for Footnote 2 -- https://github.com/erlang/otp/
So from your meap I can click the links and be taken to the websites!
All well under 1 minute!!!

Tools -> Advanced Editing -> link tool
lasso Footnote 1 link, chose invisible rectangle
select radio button "Open a Web Page" -> Next
in "Edit URL dialog" enter the url https://github.com/erlang/otp/ -> finish
File -> save
close/open meap
open page 17 -> click link and it takes you to the web site.
You should be able to edit "Any" pdf document from "Adobe Acrobat"
unless security restriction!
To create links in pdf is very easy. Literally a No Brainer!!!

Your editor is not using the "Proper Tools" to create your book!!!
They should be using "Adobe's Acrobat!"
You should consider trading this Editor for a more competent Editor

For Instance: Help from acrobat 9 (old version) :

1)-- Create web links

Choose Advanced > Document Processing > Create Links From URLs.
In the Create Web Links dialog box, select All to create links from all URLs in the document, or select From and enter a page range to create links on selected pages.

2)-- Navigate with links

Choose the Select tool .
Position the pointer over the linked area on the page until the pointer changes to the hand with a pointing finger. A plus sign (+) or a w appears within the hand if the link points to the web. Then click the link.


Links can take you to another location in the current document, to other PDF documents, or to websites. Clicking a link can also open file attachments and play 3D content, movies, and sound clips. To play these media clips, you must have the appropriate hardware and software installed.

The person who created the PDF document determines what links look like in the PDF.
Note: Unless a link was created in Acrobat using the Link tool, you must have the Automatically Detect URLs From Text option selected in the General preferences for a link to work correctly.
src="bottle.png"
the download provides image "beer.png".( I'm typing along)

using netbeans 7.4, started html5 project. (Strip out boiler plate to your liking).
right click (project name) -> properties -> just include any *.min.js you want(choice of dozens)
with google plugin, on each save, refresh chrome to see changes.
the html5 and js code completion is second to none
netbeans 7.4 makes this a real "Joy"
pdf page 6
Figure 1.1's text appears washed-out

Enjoyed your last book and the dart newsletter
This book should be great!
I would like to see pdf page 40 , Lambda expressions as page 1.
Revisiting java prior to jdk 8 turns me off, but that's just me.
I also like typing along.( A copy of the code is handy though.)
I'm a type along guy, like in building a project incrementally.

You guys are clearly "Virtuoso's" in the Industry.

Thank you,
douglas
arduino rules
would the synergy of aspectj/springaop , take java8 to new levels?
And be more useful with java8?
Maybe Along with scala/clojure in the "Beyond Java 8 Chapter".
1) - In "Your" netbeans installation, navigate to:
Csmilierogram FilesNetBeans 7.4etc, Then open netbeans.conf file.
Then scroll to the bottom of the page and replace netbeans_jdkhome= with your jdk installation
mine was "netbeans_jdkhome="Csmilierogram FilesJavajdk1.8.0"

2) - Go to File -> Open Project, your pom may be entered for you, if that's the case just click Open Project.
If Not click the arrow on the right hand side of the Look in: box and navigate to the pom file
Mine was located in "B:TutorialsLamdasInActionJava8LambdasInAction-master".

3)- open the FilterApples.java file in the editor contained in package lambdasinactionn.chap1, Then
click the green arrow in the toolbar and netbeans will
happily compile and run your java file. make sure the file
is selected in the Projects pane or active in the editor
will angularjs 2.0 be the books new base for coding?

Is there a new book completion date?

angularjs 2.0 is described as:
"significant departure" from version 1.x
"drastically different looking framework"

Will version 2.0 make this book antiquated?
for the code to actually run:

the existing:
angular.module('helloApp')

needs to be:
angular.module('helloApp', [] )
yes/no?

Adobe's open source "Brackets" editor/ide is a great
compliment to this book.
the html editor can be easily included via instructions:
http://lizusefulstuff.blogspot.com/2012/07/how-to-add-html-editor-for-eclipse.html

the scala plugin for eclipse juno
http://scala-ide.org/download/nightly.html
With PostgreSQL 9.1 the top end of scalability was approximately 24 cores and 75,000 transactions per second. In contrast PostgreSQL 9.2 can now scale up to 64 cores and 350,000 transactions per second.
I was offering some transaction performance for no particular reason

but while I'm here:
pdf page 124, 6.5.1 , "Java EE traditionally defines three scopes"
and then 4 scopes are listed then explained

pdf page 6.1.3 Creating our first controller
#1 the controller java file we are going to create(?)
to maybe: the controller explained.
do independent modules achieve that?
then everything is agnostic with central dispatcher?

This play philosophy has no bounds, the architecture reflects that?
I used java -jar h2.jar

cd /play-2.0.4/repository/local/com.h2database/h2/1.3.158/jars$ java -jar h2.jar

this is the way to go for now?

H2 web console:
Book says play 2 doesn't support this yet(TODO) page 73
yuk!
using play-2.0.4, tried 1.2.5 but no ebean was available

I got the evolution though with 2.0.4. Is this feature tool @db , H2 web console, going to be available before the book is finished?, if not, ???,or are we to ignore these pages with the h2 web console altogether?
is the reduction in features do to
the adoption of scala?
where is this sample code archive?

"you could switch to the application for this
chapter from our -- sample code archive --. We’ve set it up so it preloads a bunch of test
data using the evolutions mechanism. Just run the application, and it will populate
the database on the first request."
I found an anomaly in closing run in
windows 7

click in the terminal window
type exit, the terminal will not echo your keystrokes
you will be taken to the play prompt
otherwise ctrl - D with enter does nothing
same for ctrl - C with enter
return notFound(format("Pro...
to return notFond(String.format("Pro...

pdf page 55
in listing 3.21 to the start of the...
the listing I believe refers to Listing 3.14
input type="submit" class="btn primary"

Why would you use a name with a space in it?
Is there a practical use?
thank you

I looked in the public folder
,stylesheets and opened main.css
it was empty. So, these id's and classes
reside in the ether? for demo code?
import views.html.products.list;
list cannot be resolved

What I did was a ctrl-D , eclipsify, ~run
right click the project name and refresh
and everything was back to normal

something is not updating the other and such....
page 46/49

products displayed in browser twice
with no additonal point

will the pencil icon be available?
it is redundant
also on page 46 in your description of
the render you have product which
might mean produces
please use netbeans 7.3 Beta for your book, synergy guaranteed!!

netbeans ide 7.3 Beta now includes a full html5 css editor

Your book can use netbeans for all play coding!!!

when you change css you do not need a save, the change is shown immediately
in a chrome browser! WOW!!!

http://netbeans.org/kb/docs/web/html5-gettingstarted-screencast.html?intcmp=925655

Just now!!! netbeans 7.3 beta is releasd, As you resize your editor
chrome resizes synchronously. Also there is a menu to view your code in phone,tablet,pc,etc simulation.

maybe along with javafx's Scene Builder

now you got the tiger by the tail
This chapter covers:

(maybe it should saysmilie
re-visiting installing and running Play 2
re-visiting Setting up an IDE and debugging

but I'm not sure where this occurs?
Is the use of symbols for generics either or (<>, [])?

pdf page 46
@(products: Set[Product])

Footnote 2 In Scala syntax, generic type arguments are indicated using "SQUARE" brackets instead of angle brackets.

pdf page 48
public static Result list() {
Set<Product> products = Product.findAll();
return ok(list.render(products));
}
ctrl-d
ctrl-c
do not work for play in windows 7
I will use debian squeeze on oracle's virtual box
If I had a server it wouldn''t be windows anyway
no, I moved everything to debian

If what I understand of the play concept is correct
Play would be a boon to Adobe's Dreamweaver
A Play extension would be needed though

or interface with oracle's javafx Scene Builder gui
ctrl-d does not stop play, must use Task Manager
windows 7 , oracle java 1.7

eclipse complained about "index" use
in controller code
with all jars present
Your newsletter announced the Dart V1.0 today
Will the Dart In Action be updated?
the number of expected replies ; expectedReplyCount++

is there a way to ping the receiving isolate to provide a "Boolean"
if the receiving isolate is shutdown unexpectedly, In addition to
counting the expected replies. Or give a timeout limit to wait for reply?
pdf page 346 TIP:

I believe when creating virtual machines
you can configure 4 virtual CPU's for each physical CPU present.
So with 4 physical cores you could virtualize 16 machines, (memory available
withstanding.)
So,could this be a starting point for worker isolate's?
sourceforge Whonix
bullet proof from hackers
http://sourceforge.net/p/whonix/wiki/Home/
Great book!!!

Dart is a moving target, maybe a list of changes , additions, improvements, etc.
could be in a file named "Dart target Snapshot"( a current cheat sheet)". It would only include a column for api past and a column for api now.So changes could be readily found and made.

Dart ide version M4, Eclipse platform.

The netbeans ide has a built in "Driver" for google's chrome.
When typing javascript or html5 etc, in the same file, any save in code
does an automatic "Reload" in chrome.
The netbeans ide supports using
more than one language in the same file. Wouldn't netbeans be a better choice
as the platform for the "Dart Editor"?

Dart is a moving target, maybe a list of changes , additions, improvements, etc.
could be in a file named "Dart target Snapshots"( a current cheat sheet)".It would only include a column for api past and a column for api now.So changes could be readily found and applied.
If your not using maven,
create a HBaseIA project in the "Amazing" Netbeans 7.2

type in code ,(the package for UsersTool.java should be HBaseIA.TwitBase.cli)

go to run -> Clean and Build Project

then Window -> output -> terminal
navigate to the HBaseIA dist directory
type in the command from book and you get:

12/08/18 12:17:58 INFO zookeeper.ClientCnxn: Socket connection established to localhost/192.168.0.42:2181, initiating session
12/08/18 12:17:58 INFO zookeeper.ClientCnxn: Session establishment complete on server localhost/192.168.0.42:2181, sessionid = 0x1393abe9c110003, negotiated timeout = 40000
Succesfully added user <User: HMS_Surprise, Patrick O'Brian, aubrey@sea.com, 0>
douglas@ubuntu:~/NetBeansProjects/HBaseIA/dist$

hbase(main):002:0> scan 'users'
ROW COLUMN+CELL
HMS_Surprise column=info:email, timestamp=1345317479087, value=aubrey@s
ea.com
HMS_Surprise column=info:name, timestamp=1345317479087, value=Patrick O
'Brian
HMS_Surprise column=info:password, timestamp=1345317479087, value=abc12
3
HMS_Surprise column=info:user, timestamp=1345317479087, value=HMS_Surpr
ise
1 row(s) in 0.1440 seconds
I goofed didn't see the innerclass or look for one
But I did put a Long tweetCount in the abstract class

pdf page 33

Put p = mkPut(new User(user, name, email, password));

User is an abstract class

package HBaseIA.TwitBase.model;
public abstract class User {
public String user;
public String name;
public String email;
public String password;
@Override
public String toString() {
return String.format("<User: %s, %s, %s>", user, name, email);
}
}
the book is an enjoyable read.

the extra mile:

at the beginning of each chapter , the chapter's "contract" of what extent the material will be explained and demonstrated, would probably be of interest to a technical orientated reader.But the index would suffice
for the rest of us.

A large number of readers would most likely enjoy this presentation as I do.

reading lab reports, briefs, statistics, legal arguments is another type reader.
Nick,
using debian squeeze

[ERROR] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Compilation failure
error: error reading /root/.m2/repository/asm/asm/3.1/asm-3.1.jar; error in opening zip file
Using "Maven2 etc." in a business environment
would be like playing another version of Russian Roulette.
running mvn assembly:assembly
gets:
[INFO] Unable to find resource 'org.mortbay.jetty:jsp-2.1:jar:6.1.14' in repository apache release (https://repository.apache.org/content/repositories/releases/)
Downloading: http://repo1.maven.org/maven2/org/mortbay/jetty/jsp-2.1/6.1.14/jsp-2.1-6.1.14.jar

434/847K 347/444K
A very popular server,
but then when download proceeded I got this:

[ERROR] Failed to execute goal on project hbase: Could not resolve dependencies for project org.apache.hbase:hbase:jar:0.92.1: The following artifacts could not be resolved: org.mortbay.jetty:jsp-api-2.1:jar:6.1.14, org.mortbay.jetty:servlet-api-2.5:jar:6.1.14, org.codehaus.jackson:jackson-core-asl:jar:1.5.5, org.codehaus.jackson:jackson-mapper-asl:jar:1.5.5, org.codehaus.jackson:jackson-jaxrs:jar:1.5.5, org.codehaus.jackson:jackson-xc:jar:1.5.5: Could not find artifact org.mortbay.jetty:jsp-api-2.1:jar:6.1.14 in apache release (https://repository.apache.org/content/repositories/releases/) -> [Help 1]
[INFO] HBaseIA/TwitBase/coprocessors/RelationCountImpl.class already added, skipping
[INFO] HBaseIA/TwitBase/Md5Utils.class already added, skipping
[INFO] log4j.properties already added, skipping
[INFO] META-INF/maven/ already added, skipping
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESSFUL
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1 minute 17 seconds
[INFO] Finished at: Thu Jul 05 08:52:13 EDT 2012
[INFO] Final Memory: 31M/88M
[INFO] ------------------------------------------------------------------------
douglas@debian:~/twitbase$


It seems that Someone has fixed the corrupt file
but before that I downloaded the asm and dragged it into the proper .m2 location
the HBaseIA is no longer available at git

neither is it available at this location
page 17 Chapter 2
last line

you might want to change the existing link to your new one

Downloading: http://repo1.maven.org/maven2/tomcat/jasper-compiler/5.5.12/jasper-compiler-5.5.12.jar
185b downloaded (asm-3.1.jar)
[WARNING] *** CHECKSUM FAILED - Checksum failed on download: local = '6c9fd3d150b8a5f0ca676f49b8ed603793cabebb'; remote = '<html>
<head><title>301' - RETRYING
Downloading: http://maven.glassfish.org/content/groups/glassfish/asm/asm/3.1/asm-3.1.jar
185b downloaded (asm-3.1.jar)
[WARNING] *** CHECKSUM FAILED - Checksum failed on download: local = '6c9fd3d150b8a5f0ca676f49b8ed603793cabebb'; remote = '<html>
<head><title>301' - IGNORING
Downloading: https://repository.apache.org/content/repositories/releases//org/slf4j/slf4j-log4j12/1.5.8/slf4j-log4j12-1.5.8.jar
395K downloaded (jasper-compiler-5.5.12.jar)


***************************************************************
this repo downloads 1k at a time from this point on (287/444k)

Downloading: http://repo1.maven.org/maven2/org/mortbay/jetty/jsp-2.1/6.1.14/jsp-2.1-6.1.14.jar
1000K downloaded (jsp-2.1-6.1.14.jar)
287/444K
it sat with that output with no further downloading
for over 1/2 hour before i did ctrl-c
java is now java7
ubuntu is now 12.04

before starting the next chapter
delete table 'mytable'?
top of page , first block of code

The constructor Get(String) is undefined

using:
import org.apache.hadoop.hbase.client.Get;

private static Get mkGet(String user)
{ Get g = new Get(user);
return g;
}
Rather than putting the hbase to practical use

The book is going to discuss the source code for hbase?
page 26
maybe you can direct us to
http://opentsdb.net/getting-started.html
to install opentsdb so we can run the mkmetric commands
will there be sample data to insert into mysql?
having not read your recent re-write, I don't know if mysql is featured again ,
but your gushing over mysql with the performance/analytic s monitor seemed
out of place in your first writing attempt!
You don't need to be sorry, this is MEAP!
I used the debian install instructions from the cloudera web site
and to boot, I got a daemon ready to go,with user hbase

https://ccp.cloudera.com/display/CDHDOC/CDH3+Installation#CDH3Installation-InstallingCDH3onUbuntuandDebianSystems

This book is an enjoyable read so far.

It would be nice if you also used Erlang
If you turn the free aspell or similar loose, it will save lots of work, I think?
page 48 pfg

3.1.1, What's the difference

4 sentences down, The Arduino works digital pins work in the same way ...

page 51 pdf

under Figure 3,3
2nd sentence
this is the one the want to connect ...
The arduino ide works fine in windows 7, so far.

But, in debian squeeze, 64 bit, the arduino ide uploads fine,
then suddenly, without any obvious reason, it fails to upload,

dmesg: confirms that arduino UNO is recognized.

also,during the failed upload, the L,TX,RX as well
as the led in pin 13 blink on and off,so it's sending something to the board, but, it looks like the board
doesn't understand what it is.

I use the ide with sudo ant run.
I checked the forums and didn't see anything similar to my debian mystery.

Is this a known issue?
the serial monitor outputs serial enigmas

the sketch doesn't contain any code that would produce the output
shown in Figure 2.13

I'm using debian squeeze 64bit on oracle's vm virtualbox
I use sudo ant run;

A few typo's along the way, but It looks like we are going to
get a thorough understanding, I'm enjoying the book .
uno
idProduct 0001
arduino-0022
cdc_acm 2-2:1.0
RXTX-2.1-7

Thank you
Looks like a lot of fun ahead

using windows 7 64 bit
The ide runs but...

Pdf, page 14, I copied and pasted the code into the ide,
when I clicked the verify tool button.
ide complains stray '#' in program,

7 errors in all reported,(error expected ';' before '}' token) and so forth.

Iis there a README somewhere
for a windows7 ide install?
_id: new ObjectId("6a5b1476238d3b4dd5000048"),
{ _id: new ObjectId("6a5b1476238d3b4dd5000048")

I don't get the new use here. I thought that using "new" with a constructor, in this case
would need a unique parameter?
Yes that worked, thank you

so far it's an enjoyable read
ruby connect.rb completes; no exceptions raised

but if I use:
it doesn't work

douglas@debian:~$ irb -r connect.rb
<internal:lib/rubygems/custom_require>:29:in `require':LoadError: no such file to load -- connect.rb
irb(main):001:0>
1)-In this case the resolver or what ever did not do this for the lift install
the maven2 lift install "Failed",

2)-by bypassing this resolver or whatever else is involved
the maven2 lift install was "Successful"

these lift maven archetypes, are full of errors, mostly versions

automation lisping?
while trying to get a maven sbt version to work with the book's code I got :

1)-- Maven pom.xml created from : net.liftweb:lift-archetype-sbt_2.8.1:2.2-RC3
<dependencies>
<dependency>
<groupId>net.liftweb</groupId>
<artifactId>lift-mapper</artifactId>(*lift-mapper should be lift-mapper_2.8.1)
<version>2.2-RC3</version>
</dependency>

2)-
Error: error while loading JUnit3, Scala signature JUnit3 has wrong version
information:15 errors
0 warnings
ConsoleRunner has wrong version
Examples has wrong version
and a bunch more wrong versions

3)--Clearly The archetype shouldn't be offered
the unexpected sbt/lifty failures,
without first manually installing repositories.
may be the same one I experienced with Maven2

to get the lift deal to work in Maven2,
I had to edit the pom's repository entry

from : http://scala-tools.org/repo-releases

to: http://scala-tools.org/repo-releases/net/liftweb

aside from the Boot needing an entry, wrong versions, etc
everything else worked fine
I just created the same project in netbeans and intellij
this time it worked? Using Ubuntu 10.04 , sun jdk , now

Other inconsistencies;

1)--from repo1.maven.org:
metadata>
<groupId>net.liftweb</groupId>
<artifactId>lift-mongodb_2.8.1</artifactId>
<version>2.2-RC1</version>

<versioning>

<versions>
<version>2.2-RC1</version>
<version>2.2-RC2</version>
<version>2.2-RC3</version>
</versions>
<lastUpdated>20101217145359</lastUpdated>
</versioning>
</metadata>

2)- from assembla .com
Maven users
Add dependency to your pom:

<dependency>
<groupId>net.liftweb</groupId>
<artifactId>lift-mongodb</artifactId>
<version>2.0-XX</version>
</dependency>

3)- maybe mention when this happens, how to visit
the repo concerned, A simple answer.
IDE netbeans and tomcat

also I just downloaded the MEAP update

pdf page 25

1)---did the sbt interview in console
2)--- *lifty is org.lifty lifty 1.2 , Failed

the *ScalaToosSnapshot had to installed manually, before *lifty is org.... would Work!
This is the same as before, using Fedora 14 , sun jdk 1.6_21
[2]-- New syntax?

div id ="main" class="lift:surround?with=default;at=content"

Message was edited by:
douglasv