Here's how to get it working in python 3.x if anyone is curious: http://stackoverflow.com/a/28500470/64690
The image is too grainy to be able to read. A higher resolution image would be helpful.
Looks like I needed python 2.7, now it works like the book. Since python.org recommends learning v3 for those just learning it I'd recommend describing the configuration you're using.
I've been trying all day to get listing 3.1 working. First off, I'm running on Windows (Python 3.4) and I've finally gotten everything installed correctly (scikit-learn, numpy, pysci, matplotlib) - none of which is mentioned but assumed it's installed and working. I've also been trying to get it all installed on CentOS but matplotlib just won't install - I can build it but not install.

Now when I try and run :

import numpy as np
from sklearn import datasets

iris = datasets.load_iris()
np.array(zip(iris.data, iris.target))[0:10]


I get the following:

>>> np.array(zip(iris.data, iris.target))[0:10]
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
IndexError: 0-dimensional arrays can't be indexed


Have I done something wrong or is the sample incorrect?

maybe installing npm from dev branch isn't the best idea. I followed the directions and when I tried to search it blew up. Having the instructions for a known stable build would be better
A small thing, but I haven't tinkered w/ node.js in a while. In chaper 2, for your first "Hello World" example. It would be helpful to let the reader know how to exit the loop. I had to google that one after trying "exit", "quit" I finally hit CTRL+C. I know the proper way now, but its' a small thing that would be very helpful.