The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

Just a heads up. I ran into a ceiling starting up additional VM's today. The issue turned out to be all the RAM on the host was allocated to other VM's. Stopping those VM's did not aliviate the issue, but deleting a VM to free up enough RAM did. Some digging shows that overcommitment is possible, but disabled by default.

http://www.sebastien-han.fr/blog/2012/09/22/openstack-memory-overcommit/

You might want to consider mentioning this in chapter 2, or use smaller flavors. Running 4 GB instances will eat up most of the resources that most test system will have quickly. smilie
Thought I would give you some quick info. It looks like things are currently kinda broken for 14.04. I ran into the following issues:


This one has a work around,

https://bugs.launchpad.net/devstack/+bug/1316328

But even after that I ran into issues with networking, specifically adding the router gateway. I got a SIOCADDRT: Network is unreachable error. The same config file worked correctly on 12.04, though I did run into issues with the tempest client. I had to disable that in the config. It sounds like another known issue with a python update.

https://bugs.launchpad.net/subunit/+bug/1274056

Might have some time to dig into it more later, but at least now I'm getting successes on the exercise!
Hey Cody,

Thanks for the update, and no prob. I'm already a little further in my understanding of Openstack then my previous attempt got me! smilie

Just an FYI: I checked out the source code on github, and it matches the current (incorrect) version in the book, however the .zip file contained different versions. They are still not working 100%, but look like they are closer. If those are the correct versions just let me know and I'll dig into it a little more. I don't want to spin my wheels on stuff we know is incorrect.

Looking forward to the next update!
I've run into some similar issues. I figured out the issue with the local.conf file not being picked up by changing the header to:

[[local|localrc]] ( see http://devstack.org/configuration.html )

however now when I run exercise.sh most of the components fail.

SKIP docker
SKIP swift
SKIP trove
PASS aggregates
PASS client-args
PASS client-env
PASS sec_groups
FAILED boot_from_volume
FAILED bundle
FAILED euca
FAILED floating_ips
FAILED horizon
FAILED neutron-adv-test
FAILED volumes


I /think/ it has to do with networking, as I'm seeing a lot of 'Cannot open network namespace' and 'couldn't ping server' messages, but I have not been able to track it down yet. I did try with Ubuntu 14.04. I'm building a new VM with 12.4 in case that had any effect on it.