individuellaberschnell (1) [Avatar] Offline
I got a little problem regarding this...
Im using the loader from Josh DeFord & Eric Miller (
I checked if the animation itself is exported correctly with the included demo application and everything looks fine.
But I just cant get the animation to work in my own application smilie
I did set an Alpha & SchedulingSphere, the "isBehaviorSchedulerRunning()" returns true (after a little while) and the behavior node is active... but still, no movement at all.
After I checked the class files in the loader, i saw a method called "turnOnBehaviors", but theres no sourcecode provided, so I got no clue what exactly is done inside that function.
Also, I checked all those java documention and did everything it told me to do, or so i thought... i'm really stuck here, could anyone help me out a little here?
jdeford (2) [Avatar] Offline
Re: Problems with animation in an imported 3D model
After doing a google search I found this posting. Are you still having a problem? Here are some things to try.
The demo provided with the loader allows you to load 3ds files while its running. The jar file should be double clickable as long as your associations are set appropriately.
Otherwise you can run the demo
"java -jar Lader3DS1_2.jar com.microcrowd.loader.java3d.max3ds.Main"
(The loader has been repackaged)

The file menu will allow you to load your model from into the demo and your animations should be active in it.

From that point, you can look through the demo code to see what the demo is doing. From sourceforge you can download the source with a cvs client. But if you don't want to do the cvs thing I've also posted the source as another release file.

One last thing. I have seen problems with 3DStudio Max's export functionality. I've exported to 3ds format and then, when I tried to open the new 3ds file 3d Studio it was trashed. This problem can't be solved by the loader so you may want to see if it is exportable and importable by the loader.

Let me know if I can help further.

-Josh DeFord
jdeford (2) [Avatar] Offline
Re: Problems with animation in an imported 3D model
ahh. I reread your posting and see you already did some of my suggestions. You could always try to copy the Main demo code into your main file and work backwards from there until you get it running as you want..
dselman (104) [Avatar] Offline
Re: Problems with animation in an imported 3D model

Thanks for the help! I was out of my depth there... smilie