nikola (1) [Avatar] Offline

I have a usual/unusual problem. When I try to access a CVS repository I get the following error:

[cvs] Caught exception: CreateProcess: cvs -d:ext:me@anIP:/path/to/aRepository checkout -r r1_0_0 aModule error=2.

The unusual part of it is that the cvs.exe file is in the path (I can checkout files if I copy and paste the command in the command prompt).

I'm running Win2000, cvs client that comes with cvsnt 2.0.51 (I also tried the one from The CVS_RSH system variable is set to a batch script (called using full path to the script) that calls PuTTY's plink.exe (also full path) with appropriate arguments. Content of the batch file follows:
@echo off
if ""%1""=="""" goto doneSetArgs
goto setArgs
"Csmilierogram FilesPuTTYplink.exe" -ssh -pw aPsswd %CMD_LINE_ARGS%

I'm using ant 1.6.2 (I also tried the version that comes with eclipse 2.1.3).

Please let me know if you have a solution to this problem.


ErikHatcher (211) [Avatar] Offline
Re: CVS access using ANT
Please take this issue over to the Ant user e-mail list. This forum is for discussion of the book Java Development with Ant, not for general Ant support issues.