The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

seanos11 (2) [Avatar] Offline
#1
Hi,
I am using your framework for general mouse-over and dragging along a floor plane. Similar to the WrmMapping example. but I tried to load an external model (using the ModelLoader class) as a target -it all seems to load fine, until I put the mouse over, or try drag the loaded object.

I get the CapabilityNotSetException: Shape3D: no capability to allow intersect.
I understand what is wrong.
But even using:
PickUtils.allowSetGeoPickable(loadedNode); with: PickUtils.setGeoPickable(loadedNode, true).
I still get this exception.

Can you suggest a solution.

Thanks
Sean
seanos11 (2) [Avatar] Offline
#2
Re: Pick Intersection Exception
problem found in PickUtils.
a shape can have more than one goemetry, the Util only sets the capability for one.
Suggest wrapping in for loop
from 0 to leaf.numGeometries()
iwoj (1) [Avatar] Offline
#3
Re: Pick Intersection Exception
I am having the same problem. My shapes only have one geometry in them, so bug in PickUtils is irrelevent. I have also tried using setCapability(Geometry.ALLOW_INTERSECT) directly, but I keep getting the same exception. Has anyone actually used geometric picking successfully?