import-bot (20212) [Avatar] Offline
#1
[Originally posted by mtedone]

Hi, I want to use the mail target to automatically send an email for my
release. I'm using James as mail server and I must say that it works fine with
the usual email clients. If I send an email to myself, everything works fine,
except from the fact that I receive the following output from the console:

[mail] Failed to initialise MIME mail

If I send the email to an external email address (let's say a mailing list), I
receive the following error:

[mail] Failed to initialise MIME mail
[mail] Sending email: [ANN] A new Jamailet version is available
[mail] Failed to send email

BUILD FAILED
filesmilie:/Builds/build.xml:107: IO error sending mail

Do you know why?

My email target looks like the following:

<target name="mail">
description="Mail james list about a new version">

<mail from="${from.recipient}" subject="${mail.subject}" >
<to address="to.recipient" />
<cc address="cc.recipient" />
<message src="${mail.message}" mimetype="text/plain" />
</mail>


</target>
import-bot (20212) [Avatar] Offline
#2
Re: mail target gives me an IO error
[Originally posted by mtedone]

Sorry there was an error in my previous post. My mail target looks like the
following:

<target name="mail">
description="Mail james list about a new version">

<mail from="${from.recipient}" subject="${mail.subject}" >
<to address="${to.recipient}" />
<cc address="${cc.recipient}" />
<message src="${mail.message}" mimetype="text/plain" />
</mail>


</target>

but the result doesn't change. I still get an error.

Marco
import-bot (20212) [Avatar] Offline
#3
Re: mail target gives me an IO error
[Originally posted by mtedone]

Problem solved. Actually there were two problems:

a) I hadn't mail.jar and activation.jar under ant_home/lib;
b) My SMTP server required authentication, and currently there is no way to
specify authentication information from the <mail> target.

Marco