The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

import-bot (20211) [Avatar] Offline
#1
[Originally posted by marim]

Hi there,

I'm coding the video poker machine making some little changes (object names
and strings) related to the language (portuguese). Everything was running ok
until the XML report. When I run it (I'm using Visual Studio) the system shows
me the following message:

===========
An unhandled exception of type 'System.Xml.XmlException' occurred in
system.xml.dll

Additional information: System error.
===========

I compared my code with the book and everything is OK. I supose it's is caused
by something else because the app compiles and starts running, the problem
occurs at line 59 -> xt.Transform(xd, null, tw);

In addition, Visual Studio gives me a message that this method is obsolete and
asks me to pass XmlResolver to Tranform().

What should it be?

Thanks in advance and congratulations for the book, that's great.

--
Flávio
import-bot (20211) [Avatar] Offline
#2
Re: Problems with XmlRep
[Originally posted by marim]

> Hi there,
>
> I'm coding the video poker machine making some little changes (object names
> and strings) related to the language (portuguese). Everything was running ok
> until the XML report. When I run it (I'm using Visual Studio) the system shows
> me the following message:
>
> ===========
> An unhandled exception of type 'System.Xml.XmlException' occurred in
> system.xml.dll
>
> Additional information: System error.
> ===========
> What should it be?

Hi Flávio,

This problem occurs due to special characters in xsl file. As you told, you
are writing some strings in portuguese. Your idiom has many characters like
"á", "ó", etc. Try removing special characters in your xsl file and the
program will probably run.

--
Flávio