The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

ForumJason (8) [Avatar] Offline
#1
I've tried all of the instructions in Chapter 2 from the command-line, and I could not get it to work (a parse error with dockerrun.aws.json). So I deleted everything in AWS and ran the create_ebs_env.sh script from the Chapter 2 repo. Everything succeeded, but I get 404 errors when I try to access the __version__ endpoint (or any other endpoint in the application).

I did notice that the main invoicer repo has "AWSEBDockerrunVersion" in the app-version.json file set to "2" instead of "1", so I may try that.

I also noticed that the latest Amazon Linux/Docker image retrieved by the script is one with Glassfish 5.0 and Java. I am able to curl (and visit) the main URL and get a "next steps with Glassfish page".

Assuming the issue is not the app-version.json discrepancy, I wonder if I should hard-code the Amazon Link/Docker image to use?
Julien Vehent (14) [Avatar] Offline
#2
Thanks for the report! This is likely caused by the Glassfish container being listed first in the AWS response. I've updated the script to pick the right Docker version. https://github.com/Securing-DevOps/invoicer-chapter2/commit/f2678d0cfa29fe393404b3baaf371b8fff446f7a
ForumJason (8) [Avatar] Offline
#3
That was fast! Thank you so much, that fixed it!