jay.pedersen (22) [Avatar] Offline
#1
New to the Xcode environment. Attempting to use the DistanceConverter project from GitHub.

The app will run, but doesn't appear to be running quite correctly on iPad (only device tested so far). When I enter a distance in miles, it does not convert to kilometers. I can enter 55 for miles and then enter 5 for kilometers in the text boxes.

The warning:
"The use of Swift 3 @objc inference in Swift 4 mode is deprecated. Please address @objc inference warnings, test your code with "Use of deprecated Swift 3 @objc inference" logging enabled, and then disable inference by changing the "Swift 3 @objc inference" build setting to "Defaults for the "DistanceConverter" target. (in target 'DistanceConverter')

Any hints?

I am just trying to see if I can run the project as-is from GitHub. I will later build from scratch from following along with the video.
Craig Grummitt (50) [Avatar] Offline
#2
Hi Jay, thanks for the feedback and letting me know about the warnings. They're not going to impact your project much, but in any case, I have updated the repositories to fix these warnings.

Regarding your comment that the app isn't working - what you have downloaded is actually just the initial setup of the app, ready for you to play around with, following the instructions in the videos. If you like, you can checkout different branches of this repository to see the app at different points.

Good luck with it!