The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

579195 (12) [Avatar] Offline
#1
I followed how to make a Certificate via open SSL instructions in the resources folder .

I also added trusted certificate in both firefox and chromium but it comes up with err_connection_closed .

I can type http://localhost or raspberrypi.local and it brings up the site but NOT https://

domguinard (71) [Avatar] Offline
#2
Hi,

Is:
err_connection_closed
the only error you see?
Can you screenshot what Chrome shows when you try?


Can you also also copy/paste the errors you see in the developers tools?

Thanks
domguinard (71) [Avatar] Offline
#3
Hi,

From the screenshots you sent us via email I see you are using the code from chapter 8 which does not have the secure mode enabled. Have you tried with the code of chapter 9 in the webofthingsjs-secure/ folder?

If you want to use the modified code of chapter 8 instead make sure you modify the configuration in the configuration file to enable the secure mode:

In /resources/piNoLd.json make sure that secure is set to true:

 "customFields": {
    "hostname":"localhost",
    "port": 8484,
    "secure": true,
    "dataArraySize" : 30
  }


It do agree that the book should be more explicit about that config change, we will put that in the errata, thanks for the heads up.
579195 (12) [Avatar] Offline
#4
Using chapter 9 in the webofthingsjs-secure/ folder works .

Can create your own certificates as per Building Of Web Of Things book .

In chromium you can add your own certificate and it works with https:// .
On Mozilla you have to add exception .It will show warning sign but will allow.