506426 (4) [Avatar] Offline
#1
The cdn for popper.js in listing 3.7 returns a 403 currently.

I've replaced it with https://unpkg.com/popper.js@1.14.5/dist/umd/popper.min.js

and haven't run into any problems so far.
Taubin (1) [Avatar] Offline
#2
It would probably be better to replace it with the cloudflare hosted version, as more people would have it already loaded from other websites.

https://cdnjs.cloudflare.com/ajax/libs/popper.js/1.14.5/popper.min.js
Clive.Harber (10) [Avatar] Offline
#3
Hi there

First of all thanks for reading.

I have just checked the URL provided in that listing and it is still active, it is also still being referenced from the Bootstrap site http://getbootstrap.com/docs/4.1/getting-started/introduction/. My thoughts are actually that the listing drops the integrity and crossorigin attributes that are now being enforced by browsers, especially Chrome.

I am amending the listing accordingly.

The listing for 3.7 now uses the following:

script(src='https://code.jquery.com/jquery-3.3.1.slim.min.js', integrity='sha384-q8i/X+965DzO0rT7abK41JStQIAqVgRVzpbzo5smXKp4YfRvH+8abtTE1Pi6jizo', crossorigin='anonymous')
script(src='https://cdnjs.cloudflare.com/ajax/libs/popper.js/1.14.3/umd/popper.min.js', integrity='sha384-ZMP7rVo3mIykV+2+9J3UJ46jBk0WLaUAdn689aCwoqbBJiSnjAK/l8WvCWPIPm49', crossorigin='anonymous')


Thanks for drawing my attention to it.

Clive