The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

Susan Harkins (424) [Avatar] Offline
#1
Please post errors found in the published version of Microservices Patterns here. If necessary, we'll publish a comprehensive list for everyone's convenience. Thank you for participating in the collection process. Your contributions are a great help to us and other readers.

Regards,
Susan Harkins
Errata Editor
conanconv (1) [Avatar] Offline
#2
In 3.3.4 Using a message broker, before the sub-section "OVERVIEW OF BROKER-BASED MESSAGING":
"In fact, some of these drawbacks, such as reduced availability and the need for service discovery, are the same as when using synchronous, response/response."

I guess it should be "synchronous, request/response"
Bernd Goetz (8) [Avatar] Offline
#3
page 174, figure 5.12 - the "Ticket events channel" should be the "Order events channel".

Moreover, the "OrderEvent consumer" should be the "Restaurant event consumer", I think. On page 175, the first bullet point actually explains the "OrderEventConsumer" to consume events from the Restaurant service. Why isn't the "Order event consumer" not called "Restaurant event consumer"?

Generally, it seems that the names are often not consistent (upper/lower case, concatenated)
Bernd Goetz (8) [Avatar] Offline
#4
p 169 - diagram: "<aggregate> restaurant" -> "<aggregate> Restaurant"
Bernd Goetz (8) [Avatar] Offline
#5
p. 181, listing 5.17 - the signature of the reviseOrder method is duplicated.
Bernd Goetz (8) [Avatar] Offline
#6
p. 195 - "In this scenario, Transaction A ... " -> Transaction should be lower case.
Bernd Goetz (8) [Avatar] Offline
#7
p. 277, listing 8.4 - why is the variable in the return statement called "person"? Isn't it simply the combined, flat-mapped orderDetails?
ceracm (113) [Avatar] Offline
#8
Thanks for pointing out the various issues.
ceracm (113) [Avatar] Offline
#9
Bernd Goetz wrote:page 174, figure 5.12 - the "Ticket events channel" should be the "Order events channel".

Moreover, the "OrderEvent consumer" should be the "Restaurant event consumer", I think. On page 175, the first bullet point actually explains the "OrderEventConsumer" to consume events from the Restaurant service. Why isn't the "Order event consumer" not called "Restaurant event consumer"?

Generally, it seems that the names are often not consistent (upper/lower case, concatenated)


Bernd,

Thanks for the feedback.
The book accurately represents the code so its not a typo.
However, I agree that this class should be renamed.
ceracm (113) [Avatar] Offline
#10
In section 13.4, the "Delayed Delivery Service" is repeatedly and incorrectly referred to as the "Delayed Order Service".