The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

432431 (1) [Avatar] Offline
#1
For some reason after run the command in the book, the Hadoop job is failed, I checked job log and it just says launch app failed and throw out lots of exception and keep retry many times.

I couldn't figure out where is the issue, originally I thought is my laptop issue, after tried few laptops and I can sure the example in the book has some issue.

This makes me frustrated, I start skipping the examples you provide just read it and get some ideas.

 deploy/samza/bin/run-app.sh \ --config-factory=org.apache.samza.config.factories.PropertiesConfigFactory \ --config-path=file://$PWD/deploy/samza/config/nile-carts.properties
95081 (1) [Avatar] Offline
#2
Hi and sorry for the delay answering your question.

The issue might stem from the fact that you've been using an old version of the code. It's been fully revised early November, i.e. around the time you tried.
Could you try once again from this repository instead: https://github.com/consulthys/Unified-Log-Processing/tree/master/ch05/nile-carts

I've tried again on my side and all ran fine without any exceptions