The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

538674 (1) [Avatar] Offline
#1
I've been trying to fix this for like 3 days and I'm getting super frustrated. Everytime I try to run: ng new loc8r-public --sg --st --dir app_public I get "Unable to find @angular/cli" in dev dependencies. Then it tells me to use: npm install --save-dev @angular/cli@latest . Then it tells me I can't use the new command, so then I try to ng serve just for the heck of it, then it tells me this CLI is only compatible with angular version 2.3.1 or higher. This is pretty confusing and tells me to run npm install @angular/core@latest , which also doesn't work. So then at this point I download the github version, change the heroku address and start again. What am I doing wrong? Help me obiwan kenobi, youre my only hope.
Jumy Elerossë (11) [Avatar] Offline
#2
Have you used Brew for installing Node?

I was also having problems and I fixed them using this:
cd public_app
rm -rf node_modules
rm package-lock.json
npm install --only=dev