156599 (3) [Avatar] Offline
When I execute the code of chapter 2 I get this error:

$ docker-compose -f docker/common/docker-compose.yml up
Starting common_licensingservice_1 ...
Starting common_licensingservice_1 ... done
Attaching to common_licensingservice_1
licensingservice_1 | /bin/sh: ./run.sh: not found
common_licensingservice_1 exited with code 127

What's the problem?
What should I do?

533645 (1) [Avatar] Offline
Getting the same issue.

The reason, I'm fairly sure for me at least, was that I downloaded the code from the git repository onto my windows machine. Apparently git automatically converts unix lines to windows. So many of the commands for the Dockerfile aren't working properly. First I was trying to manually convert them without too much success.

In the end I just downloaded the src zip file directly from Manning Publications website and then all the examples started working like magic.
156599 (3) [Avatar] Offline
Yes, it's true. I had already solved. Git for windows converts linux files. I solved by converting the files by hand. Thanks for the reply