The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

515749 (2) [Avatar] Offline
#1
When I run the command (page 52), mvn spring-boot: run, I get the following error
[INFO] Scanning for projects...
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 0.472 s
[INFO] Finished at: 2017-10-15T15:39:21-04:00
[INFO] Final Memory: 9M/155M
[INFO] ------------------------------------------------------------------------
[ERROR] Could not find goal '' in plugin org.springframework.boot:spring-boot-maven-plugin:1.4.4.RELEASE among available goals build-info, help, repackage, run, start, stop -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoNotFoundException


But I can start the app in STS Boot Dashboard without any issue.
I am wondering why command line and STS behave differently and how I can make command line work.
Thanks
Ji
515749 (2) [Avatar] Offline
#2
Never mind. It works now. I forgot to add the maven path
John C Carnell (44) [Avatar] Offline
#3
Hi great,

To hear you go it figured out. One of the challenges with microservices is that you have to automate, automate, automate. Otherwise, I personally find myself doing the same thing you ran into smilie.

Thanks,
John