The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

itbackyard (2) [Avatar] Offline
Dear writer,
I am following the reading book and downloaded the source code, but having following problem :
mvn wildfly-swarm:run

[INFO] Scanning for projects...
[ERROR] [ERROR] Some problems were encountered while processing the POMs:
[FATAL] Non-resolvable parent POM for ejm:chapter2:[unknown-version]: Could not find artifact ejm:ejm-samples-parent:pom:1.0-SNAPSHOT and 'parent.relativePath' points at wrong local POM @ line 6, column 11
[ERROR] The build could not read 1 project -> [Help 1]
[ERROR] The project ejm:chapter2:[unknown-version] (C:\Mobile\Coding\book\chapter2\pom.xml) has 1 error
[ERROR] Non-resolvable parent POM for ejm:chapter2:[unknown-version]: Could not find artifact ejm:ejm-samples-parent:pom:1.0-SNAPSHOT and 'parent.relativePath' points at wrong local POM @ line 6, column 11 -> [Help 2] [ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1]
[ERROR] [Help 2]

I am using windows 10 latest os
vyurik (76) [Avatar] Offline
I concur with this message.
There is a problem in ejm-samples-master pom.xml.
Mr. Finnigan, is it possible to have source code built and run out of the box?

itbackyard (2) [Avatar] Offline
Any updates regarding this so far?
285376 (1) [Avatar] Offline
Ken Finnigan (20) [Avatar] Offline
Hi all,

Firstly I need to apologize for my delayed response.

I saw the message come in but was unable to respond at the time and then I let it slip off my radar.

I will be updating and fixing issues with the sample code over the next week.

Thanks for your patience
424904 (1) [Avatar] Offline
Any update on this issue? I just purchased the MEAP and downloaded the code, receive same error as above.
Ken Finnigan (20) [Avatar] Offline
I tried reproducing this problem again today and was unsuccessful.

If I go into /chapter2, with nothing in my local M2 repo for the projects, and run `mvn clean install` it works ok. I don't get any errors about missing parent poms.

Am I not trying the same thing as you've had issues with?

vyurik (76) [Avatar] Offline
Mr. Finnigan,
Is there a preferred operating system for building and running your book source code?
Or it's supposed to run on Mac OSX, Linux, Windows?
I am asking because in previous experience with Microservices Windows usually fail to build/run Microservices.

Thanks for your answer,
vyurik (76) [Avatar] Offline
Which version of source code?
Dear Author,
Which version of source code is correct if there is difference between GitHub code and Manning book site code?
For example, Chapter 2 GitHub code does not contain /chapter2/jaxrs directory, but the Manning book site code does have this direcotry.

Ken Finnigan (20) [Avatar] Offline

There isn't a preferred operating system. Personally I'm doing everything on a Mac, but I also run tests on Windows on occasion. It should certainly work on any operating system.

With respect to the source code, the up to date version of source for the book is currently with the book. I'm in the process of changing a lot of the examples for the book which are reflected in GitHub but not in the book yet.

vyurik (76) [Avatar] Offline
Thanks for your answer, Ken.
I have one problem running the book code.
It's chapter 4, Section 4.3.1.
I have attached to this message the described with screenshots,
describing the problem.
Your help is highly appreciated.
Ken Finnigan (20) [Avatar] Offline
I think there's a problem with that in WF Swarm at present, but will investigate further and let you know