The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

vyurik (76) [Avatar] Offline
#1
Greetings,
I am building/running this book applications on Windows 10 Home Edition.
Docker Community Edition for Windows prevented me to use Hyper V and forced Docker Toolbox.
Docker Toolbox seems functional since I can run the commands:
docker info and docker run hello-world

I am able to build all chapter applications with mvn clean package docker:build. However, starting with Chapter 3 I've had multiple exceptions while running docker-compose -f docker/common/docker-compose.yml up. I tried running from DOS shell and from Cygwin shell with the same result.
I have the following questions:

1. Does Docker Toolbox is good enough for this book apps or I have to upgrade Windows 10 Pro?
2. Has anyone succeeded in running all chapters apps on Windows?
If yes, what changes to app configurations have you made?
3. Are these configurations documented anywhere in the book? I followed README.md in each chapter for building and running apps.

Thanks,
Vitaly
John C Carnell (44) [Avatar] Offline
#2
Hi Vuyrik,

Several people have run into problems with Docker on windows. Take a look at this link: https://forums.manning.com/posts/list/40976.page from another post. Another reader graciously posted some fixes he had.

Thanks,
John
vyurik (76) [Avatar] Offline
#3
Hi John,
This link is my communication with surjit_sen.
I fixed this issue but there were others not related to this one.

Vitaly