MikeHT (127) [Avatar] Offline
#1
After importing the chapter 1 project into Eclipse, the pom file has an error on the following line (31):

					<execution>
						<goals>
							<goal>compile</goal>
							<goal>testCompile</goal>
						</goals>
					</execution>


The error is marked on the line withthe <execution> tag. The error is "Plutin execution not covered by lifecyle configuration".
Kostis Kapelonis (53) [Avatar] Offline
#2
Hello

The pom file is correct and contains no mistake.

The error message comes from a limitation of Eclipse and more specifically from a limitation in the m2 Eclipse plugin. The error message
happens with several other libraries/frameworks that are not natively supported in Eclipse.

The error is completely harmless and if you run Maven from the command line (as you should anyway) you will see that the pom file is perfectly fine.

There are ways to disable this warning (if you search it on Google you will find a gazillion of answers).

See here for more information

https://www.eclipse.org/m2e/documentation/m2e-execution-not-covered.html

In summary, this error is completely unrelated to Spock.
MikeHT (127) [Avatar] Offline
#3
Thanks