kildem (6) [Avatar] Offline
#1
The last react-router version is v.4, but in the example (server side rendering) the book use v.3. Since this is a new book, why don't you use the last react-router version?
Elyse Kolker Gordon (9) [Avatar] Offline
#2
Hi,

The book was started before React Router 4 was released. However, before publication we will evaluate updating to current versions of several of the libraries used.

In the meantime, React Router 3 is fully supported by the React Router team.

Thanks,
Elyse
kildem (6) [Avatar] Offline
#3
Thanks,
I really hope you could update various libraries to the last version smilie
Elyse Kolker Gordon (9) [Avatar] Offline
#4
Yep, I would definitely like to do the major things used - including webpack and react router. Obviously these will get out of date again after publishing, but that's the nature of the beast smilie