towst (4) [Avatar] Offline
#1
Section 9.3.2 in MEAP V15 states that the "RequiredModules" element doesn't actually load a module.
I've done some testing this morning on a Windows 7 system,
With PowerShell 3 the module gets loaded (provided the version meets the criteria specified in the hashtable if provided)
If PowerShell is started with "-Version 2" on the command line then the behaviour is as documented.
Being able to so this with version 3 makes it a lot easier to load modules into the global scope if that is the required behaviour which it is in my case.
Can this be confirmed and documented accordingly?