419356 (3) [Avatar] Offline
#1
Hello fellow Spark-In-Actioners,

I’m having some trouble getting Eclipse to run properly for me. It does appear on the screen but
if I go to File > New > Project (p.42), Maven won’t expand. Also, all dropdown menus become blank once I’ve viewed them once (yep, it’s true!). I never see their contents again. I log in to the VM using the following, e.g.

$ vagrant up
...
$ ssh -X spark@192.168.10.2
(and enter the password: spark)

Welcome to Ubuntu 14.04.4 LTS (GNU/Linux 3.13.0-85-generic x86_64)
…

spark@spark-in-action:~$ eclipse/java-mars/eclipse/eclipse
(eclipse appears on the screen, looks fine but is unusable)


I’m using:

System: Red Hat Enterprise Linux 7.3 (Memory: 8GB; Free Disk Space: 726GB)
Vagrant 1.9.3 (64 bit)
Oracle VirtualBox Version 5.1.18 r114002 (Qt5.6.1)

  • Can you think of something obvious that I could be doing wrong?
    Could the versions of Vagrant/ VirtualBox make a difference? (though I’d expect them to be backward compatible)
    Maybe there’s a better way than “ssh -X”?
    Does anyone else have a similar problem?


  • On p.41, they say “You can install it [Eclipse] onto your development machine or in the spark-in-action VM . The decision is all yours, because it won’t significantly affect how you build your Spark project.

    If I used Eclipse on my development machine (as opposed to the VM), would I need to install Spark on my machine or would it just be a case of copying the source files (through scp, I suppose) to the VM and running Spark jobs/programs outside of Eclipse?

    Cheers, a happy reader (but a temporarily frustrated practitioner)
    Petar Zecevic (128) [Avatar] Offline
    #2
    419356 (3) [Avatar] Offline
    #3
    Thanks for the really quick response. I tried those,which basically revolved around ensuring UBUNTU_MENUPROXY was set to 0, e.g.

    export UBUNTU_MENUPROXY=0


    before calling eclipse. Alternatively, this could be achieved by

    creating ~/.local/share/applications/eclipse.desktop with the lines

    Exec=env UBUNTU_MENUPROXY=0 /home/spark/eclipse/java-mars/eclipse/eclipse
    Terminal=false



    Unfortunately this didn't work for me. I tried running gedit on the VM and it too suffered the same menu problem so I compared the logs.
    Both had the message

    Failed to load module "pk-gtk-module", which I presume is to do with GTK+, or the GIMP Toolkit (a multi-platform toolkit for creating graphical user interfaces).
    As others appear to be using eclipse in the VM without problems, this could be with my Red Hat Linux paths or something local.

    Because I have Eclipse & the Scala IDE plugin already installed on my local development machine, I'm more than happy to use this to follow the examples in the book. I'd need to do this anyway at a later stage and would rather solve any problems that arise with this than fiddling around with possible VM/Red Hat/GTK compatibility issues (which I don't really care about).

    Thanks for your help and now ... back to the book! (lovin' it so far)