The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

214736 (6) [Avatar] Offline
#1
The standard Mac installation of git in /usr/bin/git (git version 2.10.1 (Apple Git-78)) does not provide git gui or git citool. The command
git --exec-path
reports /Library/Developer/CommandLineTools/usr/libexec/git-core. Installation directions for Mac on page 5 changed things slightly, e.g., which git reported /usr/local/bin/git, but neither git gui nor git citool worked. The following cludge seem to have worked (on MacMini and MacBookPro laptop, both running OS X 10.11.6).
  • Terminal: /usr/local/git/uninstall.sh

  • Terminal: xcode-select --install

  • Finder: update cocoaAspell

  • Finder: rerun the git-scm installer (creates /usr/local/git and executable link /usr/local/bin/git

  • reboot the computer (in one case, quitting and restarting Terminal may have sufficed; rehash might have been enough)


  • Command
    git --exec-path
    now reports /usr/local/git/libexec/git-core

    15 minutes later: The newer installation is incomplete. After the Clone described on page 19, invoking menu item Repository: Visualize master's history produces a 4-part error message in the Terminal window.

    2 days later (after uninstall, repeat install from the git-scm package):
     <path> $ gitk
    Error in startup script: unknown color name "lime"
        (processing "-fore" option)
        invoked from within
    "$ctext tag conf m2 -fore [lindex $mergecolors 2]"
        (procedure "makewindow" line 347)
        invoked from within
    "makewindow"
        (file "/usr/local/bin/gitk" line 12434)
    <path> $ git --exec-path
    /usr/local/git/libexec/git-core
    <path> $ tclsh  ## same info from wish
    % info patchlevel
    8.5.9
    214736 (6) [Avatar] Offline
    #2
  • http://stackoverflow.com/questions/17582685/install-gitk-on-mac/30021571#30021571 has a variety of comments about installing & configuring gitk on Mac


  • http://stackoverflow.com/questions/34637896/gitk-will-not-start-on-mac-unknown-color-name-lime/34682208 has specific hacks to fix the "lime" problem


  • http://repo.or.cz/w/git-gui.git has email address for developer of git-gui


  • Although use of git-gui and gotk is deeply embedded into "Learn Git in MoL", I am not inclined to try the "lime fix" hack which may just cope with a symptom rather than an underlying bug. Perhaps Rick Umali can persuade the program's developer to make suitable revisions to his code. [FWiW: it may turn out that having a full Xcode installation as opposed to just the command-line stuff is related to this bug.]