The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

Susan Harkins (424) [Avatar] Offline
#1
Please list errors found in Anyone Can Create An App here. We'll publish a comprehensive list, if necessary. Thank you!

Susan Harkins
Errata Editor
Manning Publications
479327 (1) [Avatar] Offline
#2
Figure 4.4 on page 34 displays the Utilities panel in File Inspector mode when it should be in Quick Help Inspector mode.
268326 (3) [Avatar] Offline
#3
Thanks for a very helpful book Wendy. I worked through the examples up to Chapter 22 without any problems, but now I can go further. I think the problem is in the delegates that I setup. When I click on the Done button on the AddEditViewController page I get the following message: "2017-07-23 19:20:59.265434-0700 LioN[800:231502] -[LioN.AddEditViewController doneClick]: unrecognized selector sent to instance 0x155e29ba0". The program has stopped in the AppDelegate class.

I went back over the chapter and it looks like I typed everything in ok. I even downloaded the AddEditViewController source from your site and used that and still get the error. Any suggestions?

Thanks
579120 (4) [Avatar] Offline
#4
7.1.5

. . .

myLabel.text = mytxtField.text

should be (CAPITAL T)

myLabel.text = myTxtField.text

--------------

The keyboard popped up on my first attempt to create this Project
The second time it used my iMac keyboard?

(The first time I changed the code without deleting and reconnecting, it worked until I clicked on the button)
579120 (4) [Avatar] Offline
#5
Chapter 19.3.2 refers to section 1.2.1 and 19.3.3 refers to 1.2.2

I think this should be 19.2.1 & 19.2.2.
====

Also Apple appears to have changed destinationViewController to just destination
579120 (4) [Avatar] Offline
#6
20.2.3 newLion.like = 1

Did not work for me, I think it has elsewhere, I changed 1 to true