143781 (4) [Avatar] Offline
#1
I followed the instructions in section 2.5 to set up awscli on ubuntu 14. (Amazon's online docs are a mess. Use sudo apt-get to install awscli. The pip and pip3 installations shown on Amazons doc failed for me.)

I added an IAM user with the permissions shown in section 2.5, but when I try any of the commands in the text I get error messages that don't explain what the problem is:

$ aws lambda list-functions
usage: aws [options] <command> <subcommand> [parameters]
aws: error: argument command: Invalid choice, valid choices are:

autoscaling                              | cloudformation 
...                                             | ...


Every command I try with "aws lambda" fails. The list valid of choices does not include "lambda".

Does the aws command line support lambda?