52780 (3) [Avatar] Offline
#1
On Page 23 of the eBook, the following paragraph gives instructions on how to install the Jasmine Typings:

Now in order to install the Jasmine Typings file run npm run typings -- install jasmine -
-ambient --save. Before we move on, lets make sure that our directory structure is up-todate by running the ls command. Your file structure should look like this:


When I run that command I get quite a few errors from npm, one of which is "Failed to parse package.json". I'm not familiar enough with npm, typings or jasmine to indicate what the problem is. I have attached the file npm-debug.log which may shed some light on the problem. Also, my npm libraries are somewhat newer, especially Angular2 (btw, the npm package needs to be updated from @angular/core, not angular2).

I have also attached my current package.json file.
52780 (3) [Avatar] Offline
#2
There was an extra comma in my package.json file. Once I removed that extra comma, the error I mentioned earlier did not occur, but the following command is still not producing the desired results:
npm run typings -- install jasmine --ambient --save
.

It appears that the --ambient parameter is deprecated, possibly removed in the latest version of typings (currently 2.1.0).

After I read through the typings documentation (https://github.com/typings/typings/blob/master/docs/commands.md), I was able to get the following command to work:

typings install dt~jasmine --save-dev --global


After this command, a typings folder is created for the jasmine typings.

FYI, I tried to not use the --global parameter, but it failed saying that this typing is required to be a global typing.

Jesse Palmer (28) [Avatar] Offline
#3
Ok, thanks for letting me know. I'll make sure to fix this when that chapter is updated. Let me know if you have any other issues. Thank you.

Jesse