441033 (4) [Avatar] Offline
#1
When running `./stack.sh` under devstack, using `stable/newton` on vanilla Ubuntu 16.04 LTS, I get this error:

`ContextualVersionConflict: (keystoneauth1 2.12.2 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('keystoneauth1>=2.16.0'),`

I have installed keystoneauth1==2.16.0 however, and done numerous unstackings, cleanings, and reboots.

I have attached a full log snippet.

How can I fix this error?
441033 (4) [Avatar] Offline
#2
I was able to fix this by starting over with a headless Ubuntu server vm. Apparently, that simpler set-up than my bare metal dev laptop did not have the conflicting python dependencies.
441033 (4) [Avatar] Offline
#3
Somehow, I'm back at that same error again. Tried clearing the pip cache.