352746 (1) [Avatar] Offline
#1
Section 5.3.1,

Shouldn't react and react-dom be saved as a dependency and not dev. Also its missing the install for react preset. I think it should be:
npm i --save react react-dom
npm i --save-dev gulp-sourcemaps gulp-babel babel-preset-es2015
npm i --save-dev gulp-concat babel-preset-react


Section 5.4.2
To be consistent with the previous sections, should add "cd webpack-example"


198709 (1) [Avatar] Offline
#2
Very good book !
to solve the issue in 5.3.1 Adding Gulp to a project => "A common cause of this error is the presence of a configuration options object without the corresponding preset name. Example:

Invalid:
`{ presets: [{option: value}] }` with presets: ['es2015', 'react']

I have installed babel-preset-react-es2015 in place of babel-preset-es2015 and chosen the presets presets: ['react-es2015'] in place of
presets: ['es2015', 'react']
and it works
regards