The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

38687 (1) [Avatar] Offline
#1
Hello,

I'm trying to run example 2.10 in a Jupyter notebook (python 2.3), and I'm getting the following error message:

TypeError: DataType bool for attr 'T' not in list of allowed values: float32, float64, int32, int64, quint8, qint8, qint32


The stack trace (see attached) points to line 8:

saver = tf.train.Saver()


I also get the following error message before the stack trace:

Exception AssertionError: AssertionError() in <bound method InteractiveSession.__del__ of <tensorflow.python.client.session.InteractiveSession object at 0x105c4d0d0>> ignored


...however, I got that same message on another example that worked, so that may be a red herring.

Any ideas of what I'm doing wrong?
Nishant Shukla (52) [Avatar] Offline
#2
That's a strange error indeed!

I'll take a look shortly.
454707 (2) [Avatar] Offline
#3
Hi:
I am running Python 3 (3.6) and had troubles with saving data using
saver = tf.train.Saver(). But it worked out after I used dictionary tf.train.Saver({'spike':spike}).