The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

Riaan Smith (8) [Avatar] Offline
Dear James,

I have tried multiple times, on various PC's, to build the ISO used to deploy the LAB. The DC01 server installs perfectly, but CM01 fails every time, no matter what I try. I have successfully deployed the default "Hydration" lab (not the one you supplied) on both PC's I've tried on, but I'm unable to deploy the Hydration Lab you provide. I have tried with Evaluation and Volume License versions of the software, neither seem to work.

I have attached a screenshot of the error I get while trying to deploy CM01. The error occurs at the end of the "Install - ConfigMgr" step...

I'm using VirtualBox, running the Lab on a SSD drive, and my PC is equipped with 32GB RAM, and the laptop I also tried on has 16GB RAM (also an SSD).

I would really appreciate your help with this?

Thank you,
JVinterberg (15) [Avatar] Offline
Dear "278410"

How much memory have you assigned to the VM running CM01?
It should have at least have 6GB.
If possible try to add the logfile from the failed deployment.

Kind regards
Riaan Smith (8) [Avatar] Offline
Dear Jan,

I tried it with 6GB (6144MB) RAM, as well as the 16GB on my PC at home which has enough RAM to support it. Both without success.

Which log file do you need, and where would it be located? (Apologies, but I'm still very new to SCCM and MDT, so not too filled in on where are the files are and which actions log to which files) I have the VM open on my PC, haven't started reloading it yet, so I can get you the log, no problem.
JVinterberg (15) [Avatar] Offline
Well i an on a train and can't get to my lab from here.
Please take a look on this page where to find the logs:
Have in mind that this is the mdt deployment that fails.
Riaan Smith (8) [Avatar] Offline
[ 667 KB ]
Great link, thank you...

I have attached the BDD.log file, which according to the link you posted is an "aggregated log" of all the other logs, would that be sufficient?

Thank you for your assistance.

Edit: I've just changed the VM to 8GB RAM, just to make 100% sure that it still fails - after the first failures I deleted the "HydrationConfigMgr" folder, recreated and repolulated everything, and build a new ISO. Just have to make sure that the new ISO also fails on more that 6GB RAM... Deployment currently in progress.
JVinterberg (15) [Avatar] Offline
That should be sufficient for now, but as said i am on a train, commenting with my phone, i will try to look at it later today when i return home, unless someone in this forum beat me to it.
If i haven't got back to you by tomorrow, then please make a new comment here, so i will get reminded about it. (It's the birthday of my daugther today, so i am prebooked by her, and i am already failing)
Riaan Smith (8) [Avatar] Offline
Ha ha ha, no worries, and thank you for helping me with this... Happy birthday to your daughter, hope you two have a great day!
James Bannan (21) [Avatar] Offline
Hi Riaan - sorry to hear that you are running in to issues deploying the Hydration Lab. In the root of C:\ on CM-01, there should be a log file called ConfigMgrSetup.log. Could you please post that log file to this thread?

Riaan Smith (8) [Avatar] Offline
[ 157 bytes ]
Hi James,

Excellent timing, my second test just finished (the one with 8GB RAM), and unfortunately also failed with the same Failure Notification screen as originally posted.

Certainly, I have added it for you, however, it appears rather empty? There is another one, "ConfigMgrSetup.lo_" which is much larger, but the site does not seem to allow it to be uploaded, saying its too large.

Thank you kindly,
James Bannan (21) [Avatar] Offline
Hi Riaan - if you zip the ConfigMgrSetup.lo_ file, it should compress enough for you to upload to the forum. Thanks,
Riaan Smith (8) [Avatar] Offline
You were right, it zipped down to a few KB's.

Herewith the second log...
James Bannan (21) [Avatar] Offline
Thanks Riaan - looking at that log file, it does look like that in spite of the MDT errors, ConfigMgr was actually installed successfully. Could you please check on CM-01 that SQL has been installed, and that a database has been created (it should be called CM_P01), and then check the list of available applications in the Start Menu and you should see the Configuration Manager Console. Launch it and make sure it connects to the site.

Let me know how you get on.
Riaan Smith (8) [Avatar] Offline
Hi James,

Yes SQL is definitely installed, and in SQL Server Management Studio I can see that the DB is created and the SQL Services are running. I can also see the ConfgMgr console icon, it launches without problems and indicates that it is connected to PS1...

Going to Monitoring | Site Status, it also shows all greens for the various roles that are installed. Everything appears fine, which is good - just the failure notification had me worried. But if everything is working, then I guess I should be able to complete your guide?

With that said, I do apologize for wasting your time... When I saw the errors, I never thought of checking to see if its running, I figured with a big red screen like that something had to be wrong smilie
James Bannan (21) [Avatar] Offline
Hi Riaan - no need to apologise smilie MDT errors certainly do look pretty serious, regardless of the underlying issue. Still - interesting that you don't get the same errors with other Hydration Kit installations, so I'll take a look at the BDD.log again to see what might be triggering these issues.

Riaan Smith (8) [Avatar] Offline
Thank you for your effort... smilie

And yes, you're right, the "stock" Hydration install doesn't give any errors. I even went so far as to try and "merge" the two, using your Domain Name, and IP addresses, in order to "replicate" your Hydration kit, and it worked, except I wasn't able to figure out how to deploy Windows 10 from MDT (yet). Like I said, still very new to this, and its a rather steep learning curve. But with your book I'm sure I'll have the basics mastered within a month smilie