abudden (2) [Avatar] Offline
#1
On pages 238/239 (of the PDF), there is listing 7.5: "The final Tweeter.nimble file". In the text above this listing, it says

You will need to edit this line to introduce a requirement on the jester package. To do so, simply edit the last line so that it reads requires "nim >= 0.13.1, jester >= 0.0.1". Alternatively you can add requires "jester >= 0.0.1" at the bottom of the Tweeter.nimble file.


There is no reference to jester in the "final" listing, so I think the final Tweeter.nimble file is wrong. Also, considering the discussions on https://forums.manning.com/posts/list/38451.page, I suspect that the Nim version in Tweeter.nimble (0.13.1) needs correcting.

Thanks again for a great book: looking forward to the next chapter!
dom96 (74) [Avatar] Offline
#2
On pages 238/239 (of the PDF), there is listing 7.5: "The final Tweeter.nimble file". In the text above this listing, it says


Thanks, I will fix this.

Also, considering the discussions on https://forums.manning.com/posts/list/38451.page, I suspect that the Nim version in Tweeter.nimble (0.13.1) needs correcting.


You're right, I will do that too. When I wrote the chapter 0.14.0 wasn't out yet smilie