The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

wxlund (25) [Avatar] Offline
#1
I'm trying to get local clustering to work. I've disabled the plugins on rabbit (rabbitmq_management, rabbitmq_visualiser, and by trial and error trying to start rabbit_1 & rabbit_2 also disabled rabbitmq_mqtt & rabbitmq_shovel). Now all of the servers start and my current cluster status is:

rabbitmqctl -n rabbit cluster_status
Cluster status of node rabbit@C02M43C4FD59 ...
[{nodes,[{disc,[rabbit@C02M43C4FD59]}]},
{running_nodes,[rabbit@C02M43C4FD59]},
{cluster_name,<<"rabbit@localhost">>},
{partitions,[]}]

Then on rabbit_1 I stop_app, reset and when I try to cluster I get the following:

rabbitmqctl -n rabbit_1 cluster rabbit rabbit_1
Error: could not recognise command
Usage:
rabbitmqctl [-n <node>] [-t <timeout>] [-q] <command> [<command options>]

Is the example in the book wrong?
wxlund (25) [Avatar] Offline
#2
Answering my own question. The fix for me was the following:

rabbitmqctl -n rabbit_1 join_cluster rabbit@C02M43C4FD59


I now get:

rabbitmqctl -n rabbit cluster_status
Cluster status of node rabbit@C02M43C4FD59 ...
[{nodes,[{disc,[rabbit@C02M43C4FD59,rabbit_1@C02M43C4FD59,
                rabbit_2@C02M43C4FD59]}]},
 {running_nodes,[rabbit_2@C02M43C4FD59,rabbit_1@C02M43C4FD59,
                 rabbit@C02M43C4FD59]},
 {cluster_name,<<"rabbit@localhost">>},
 {partitions,[]}]