The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

mirto (20) [Avatar] Offline
#1
At page 35 example I have this problem:
the docker terminal doesn't show any image to select.

at the url http://localhost:2375/images/json I see the images I see using docker images

but at http://localhost:8000/ I have an empty image list; so I cannot select an image to start

I'm using Kubuntu 15.10 and in this distribution the only place where you can set the docker options is the /etc/init.d/docker file
In this file I have
DOCKER_OPTS=" -H tcp://0.0.0.0:2375 --api-enable-cors "

What is going wrong?
aidanhs (25) [Avatar] Offline
#2
Hi mirto

Thanks for reporting this, there's definitely a bug in Docker introduced in 1.9.X - I've submitted a fix at https://github.com/docker/docker/pull/19569 and hopefully this will make it into 1.10.

I'm not 100% this is the issue you're seeing though, as when I try it I am at least able to get an image list. If you want to investigate a little more, my suggestion would be to open the browser console (F12 -> click 'Console' in Chrome) and see if any messages have been logged there. One suggestion off the top of my head is to double check Docker is running with the `--api-enable-cors` argument - you can run `ps aux | grep docker` to see what arguments your daemon is running with.

Aidan
aidanhs (25) [Avatar] Offline
#3
As an update, my fix has been merged and marked for inclusion in 1.10. If you see issues once you've upgraded, please report back!

Aidan
mirto (20) [Avatar] Offline
#4
Confirmed: in docker 1.10 it works.

The only problem was that the "Host:" field have a wrong value (localhost:2375)

Instead I had to fill the field wirh 172.17.0.1:2375

I found this IP with ifconfig
The value is for the docker0 network card
aidanhs (25) [Avatar] Offline
#5
Hi Mirto, thanks for confirming the fix.

It's odd you need to use the ip address of docker0, listening on 0.0.0.0 should expose the docker daemon on all interfaces, including 127.0.0.1 (i.e. localhost).

It may be worth taking another look at the first technique in chapter 2 if you're interested in debugging this. When it says `docker -H tcp://<your host's ip>:2375`, you should also be able to do `docker -H tcp://127.0.0.1:2375` and `docker -H tcp://localhost:2375`. And if these work, then so should the Docker terminal - it uses the same api as the official docker client!

Aidan
mirto (20) [Avatar] Offline
#6
Confirmed it works.
Setting DOCKER_OPTS in /etc/init.d/docker doesn't survive a daemon restart

I had to put DOCKER_OPTS in /etc/default/docker and change the systemd service at /lib/systemd/system/docker.service