The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

327744 (2) [Avatar] Offline
#1
I'm using a MacBook running OS X 10.9.5.

Tried to follow the instructions on Page 19 for cloning your website and I'm getting the following errors inside the Git Gui (screenshot also attached)...

fatal: Couldn't find remote ref HEAD
fatal: The remote end hung up unexpectedly

Please advise.

Thank you in advance.
rickumali (134) [Avatar] Offline
#2
I examined your error closely, and noticed the following:

image

In the highlighted image, the red box (pointed to by the red arrow) shows that your home directory is somehow a part of the clone URL! If I'm reading this correctly, you are typing the equivalent of:

git clone /Users/alejandro/Z/https:/github.com/rickumali/RickUmaliVanityWebsite.git

Your git clone window (figure 2.14 in the book) should be just the https part. Also, two slashes (//) follow the https, not one.

Git this a try again, making your git clone window look like figure 2.14 (substituting your directory of course).

Good luck with this, and thank you for trying out the exercise!
327744 (2) [Avatar] Offline
#3
Thank you for the fast response to my posting. I am copying in the full URL from your Github listing as the source. I don't understand why the error message in the screenshot I provided indicates that mangled URL that seems to concatenate your URL and my local directory. Very odd.

Out of curiosity I also tried cloning from the command line and that failed as well. I got the following error...
>>
The-Matrix:z alejandro$ git clone https://github.com/rickumali/RickUmaliVanityWebsite.git
Cloning into 'RickUmaliVanityWebsite'...
fatal: I don't handle protocol '/Users/alejandro/z/https'
<<

I have an different MacBook that I can try this on. I will post back later to let you know if that works.