The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

378543 (9) [Avatar] Offline
I completed chapter 2 and Command GUI went smoothly but having issue with command line on window 8.
I used git bash as explained in the book whenever I typed "git clone"­ it was saying fatal: could not create work tree dir 'RickUmaliVanityWebsite': Permission denied.

Please, what can I do?
Do we need to create target directory as we did in GUI command befor I type git clone
rickumali (134) [Avatar] Offline
Maybe the first thing to do is to type "mkdir test" in the same directory from which you typed the git clone command.

I suggest this because that is what git clone is doing: it is trying to make a directory. In the error message, this directory is referenced as 'work tree dir RickUmaliVanityWebsite'. However, for whatever reason, it cannot make this directory, because permission is denied.

If the mkdir test worked, then try this:

git clone MyCopyRickSite

Notice the extra argument, MyCopyRickSite, at the end of the git clone command. This git clone will copy the repository into a directory named 'MyCopyRickSite', which it will attempt to create. However I suspect that this won't work, and that you may be in a directory which does not allow you to make other directories.

One directory that you should use is your $HOME directory. To get to your $HOME directory, type "cd $HOME" in git bash. Then try the git clone again! Something should work, since your git gui clone command worked!

Please let me know what you find out when do the above. Thank you for reading and trying out these exercises!
378543 (9) [Avatar] Offline
Thanks very much.
I tried to type 'mkdir test' it denied me access but after changing to the home directory I typed "git clone MyCopyRickSite " it was trying to clone it by showing cloning into 'MyCopyRickSite' ..... but there was a pop up OpenSSH asking for password
378543 (9) [Avatar] Offline
Thanks very Much Rick Umali,
The thing works now after changing the directory to Home directory and then typed git clone