Susan Harkins (402) [Avatar] Offline
Please post errors in the published version of Learn Git in a Month of Lunches here. We'll compile and publish a comprehensive list for everyone's convenience. Thank you!

Susan Harkins
Errata Editor
Kunio (24) [Avatar] Offline
On page 30, 3.3 Improving command-line efficiency, 4th paragraph, it says:

> Take a look at figure 3.4. The cursor is on top of the capital F. If you press Ctrl-D,
> the letter F disappears, and all the characters move to the right. (...)

I believe the last part should be "all the rest of the characters move to the left" or something like that.
Kunio (24) [Avatar] Offline
Errata: git commit message coherence
On page 42, section 4.4, TRY IT NOW, 5th line, it says:

% git commit -m "This is the first commit message" 

But the message differs from the following listing (4.5) and a body text (page 43, 3rd paragraph, second line) which say:

This is the first commit!

And the TRY IT NOW message also differs from listings 4.6 and 4.7, which say:

"This is the first commit message!" 

with an exclamation mark.


I tried these commit messages with my Win 7 Git bash, Win 10 Git bash, and Ubuntu terminals and they all worked fine. However, my El Capitan Mac Terminal (-bash) does not work with
"This is the first commit!"
commit message, saying:
-bash: !": event not found
When I removed the trailing "!" it worked. So I think
"This is the first commit message"
should be safer (without the exclamation).

On my Mac Terminal, "which git" said "/usr/bin/git" and "git --version" said "git version 2.4.9 (Apple Git-60)". I know this Git is not recommended in "1.4 Installing Git" section. I have installed a git-scm DMG package but I could not figure out the right way to solve the PATH problem.
Kunio (24) [Avatar] Offline
4.6 Lab step 3 file name coherence
On page 45, 4.6 Lab, step 3, 1st paragraph, it says:

3. Create another file for a current Git repository, this time using echo contents > file.txt.

But the following paragraph says:

Note that this time you didn’t use the -n switch in the echo command. Now try git add on this file. If you’re on Windows, you should see the warning message “warning: LF will be replaced by CRLF in new_file. The file will have its original line endings in your working directory.”

I think new_file.txt would be better in these two instances instead of using file.txt and/or new_file.
Kunio (24) [Avatar] Offline
Errata: Figure number correction in 5.3 1st TRY IT NOW
On page 51, 5.3 Adding a file into the repository via Git GUI,
TRY IT NOW section, the last paragraph, it says:

Note that you can replace the first two commands with cd $HOME/newrepo.
After you type git gui, it will appear as in figure 5.8.

I believe that the figure number should be 5.9, instead of 5.8.
Kunio (24) [Avatar] Offline
Errata: git commit message coherence
Kunio wrote:
On my Mac Terminal, "which git" said "/usr/bin/git" and "git --version" said "git version 2.4.9 (Apple Git-60)". I know this Git is not recommended in "1.4 Installing Git" section. I have installed a git-scm DMG package but I could not figure out the right way to solve the PATH problem.

P.S. to FYI
I have installed the new git-scm DMG package (2.6.2) to my Mac OS X 10.11.1 and the PATH problem is solved.
Kunio (24) [Avatar] Offline
Errata: Figure 7.21 contents
On page 90, 7.4.4 Committing parts of a file using git add -p, Figure 7.21 includes "Working directory" and "Staging area" with two versions of "" shown in them.

But the contents are not consistent with the text.

At this time, after the Try It Now exercises in 7.4.3, the "Working directory" version should be the same with Listing 7.12 (p.87). Note that it includes one more # line before "echo $a" line.

The text in p.93 (first paragraph) and Figure 7.22 say that you are going to delete two lines containing single # marks (or removing two empty comment lines), so these two lines should be included in the "Working directory" content of Figure 7.21.

The "Staging area" should be the state after applying git add -p. In that case, single # mark line before "echo $a" should not be present in the "Staging area" content.
Kunio (24) [Avatar] Offline
Errata: Source Code zip file name
On page 96, 7.5.1 Working with multiple hunks, step 2/5, it says "Download the zip file named from the book's website" but the file name is
Kunio (24) [Avatar] Offline
Errata: 9.3.2 Deleting branches - "error" message on page 133
On page 133, just before the second TRY IT NOW section, it says "you can easily re-create it with the error message that Git provides."
On the same page, after the line
git checkout -b another_fix_branch d6cc762

it says "Notice that you specify the same SHA1 ID from the error message."
However, the message (shown in Listing 9.4) is not an error message.
It is the output from git branch -d command.
The line next to the Listing 9.4 refers to the message as "the delete message" so I think this should be used instead of "the error message" here on page 133.
Kunio (24) [Avatar] Offline
Errata: Listing 9.6 title - git checkout, not git status
On page 135, Listing 9.6 has a title "An error from git status command" but this is an error message from
git checkout master command. So the word status should be replaced with checkout.
Kunio (24) [Avatar] Offline
Errata: Lab 9.5.1 step 3, tag from the last chapter, not the first
On page 137, the first line says "3 Create a branch off the tag from the first chapter. (...)" but I think the tag should be the "four_files_galore" created in Chapter 8 (section 8.4). This is Chapter 9 now, so "the last chapter" would be the right one.
Kunio (24) [Avatar] Offline
Errata: 9.5.2 Warm-up questions no.2 and 3; section number correction
on Page 137, 9.5.2 Warm-up questions, it says "2 In section 9.2.7, you had to search for the SHA1 ID of the commit containing the string Renaming c and d."
I believe that the section number should be 9.2.2, where the SHA1 ID for the commit labeled Renaming c and d. is identified in TRY IT NOW section (p.131).

on Page 137, 9.5.2 Warm-up questions, it says "3 Section 9.2.3 introduced a lengthy git log command."
I think the section number here should be 9.2.1, in which Above and Beyond section explains how to make an alias for the lengthy git log command (see pp.125-126, 129).
Kunio (24) [Avatar] Offline
Errata: Figure 11.9 remotes/origin/new
On page 167, Figure 11.9,
in the repository labeled math.clone1,
part of a remote-tracking branch name is missing.

should be
Kunio (24) [Avatar] Offline
Errata: 11.4 Lab 2 fixing_readme branch does not exist
On page 175, lines 5-7 from top (11.4 Lab no.2), it says:

Go to the math directory and use git checkout fixing_readme.
Now make a clone of the math repository.
Confirm that the initial branch of the new clone is
the fixing_readme branch.

However, this branch is not available to most of us because (in the first TRY IT NOW section on page 133, 9.3.2 Deleting branches) we have deleted the fixing_readme branch!

So I believe that fixing_readme should be replaced with another_fixing_branch or maybe new_feature, as they are shown in many Figures and Listings in this chapter.
Kunio (24) [Avatar] Offline
Errata? chapter numbers in Chapter 13
On page 201, 3rd paragraph, the text says
"If you need a refresher on merging, review chapter 9."
It should be chapter 10 (Merging branches).

On page 204, 6th line (after git checkout -b new_branch master) the text says
"This shortcut command was introduced in chapter 8".
It should be chapter 9. It first appears in section 9.3.1.
Kunio (24) [Avatar] Offline
Errata: math directory name (p.217)
On page 217, in the paragraph after Listing 14.2, it says
Git sees that math.carol isn't in sync with the changes on math.git, and therefore a push to math.bill isn't allowed.

It should be a push to math.git.
Kunio (24) [Avatar] Offline
Errata: listing and chapter numbers on page 223-224
On page 223, after Listing 14.6, it says:
You should be able to confirm that this listing is different from listing 14.5.

But the listing 14.4 is a git fetch output. I believe the listing 14.4 should be referred here.

On page 223, near the bottom, the test says:
the branch diagrams from chapters 8 and 9.

But chapter 8 does not include vertical branch diagrams. It should be chapters 9 and 10.

On page 224, near the bottom, the text says:
you can ask Git to indicate what is different between these two branches, as you learned in chapter 9.

But the git diff command was introduced in chapter 10 (see page 143-144).

Kunio (24) [Avatar] Offline
Errata: on gitk -all
On page 248, 15.2.1 Showing only specific branches in gitk, the text says:
You can pass the -all switch to git log to get all the branches (...)
but in this case, we are passing -all switch to gitk.
Kunio (24) [Avatar] Offline
Errata: --simplify-by-decoration switch
On page 250, 15.2.2 Working with simplified views, the text says :
This view is going to be the same as what you saw in section 15.1.4 with the --simplify-by-decoration switch.

But the section 15.1.4 does not include the switch. I think it should be section 11.1.2 (see page 163-164).
Kunio (24) [Avatar] Offline
Errata: git grep text
On page 251, 15.3.1 Finding files of interest (git grep), the TRY IT NOW section says: (...)
suppose you wanted to find all the files that contained the word line. Type the following:

cd $HOME/math.carol
git grep change

So it should be the word change, not line.
jasonc (12) [Avatar] Offline
Will these Errata be confirmed and compiled into a pdf we can print off?
rickumali (130) [Avatar] Offline
jasonc wrote:Will these Errata be confirmed and compiled into a pdf we can print off?

Yes, we will be confirming and compiling these into a separate document (likely a web page). This is a work in progress, so please keep subscribed to this forum for updates.
rickumali (130) [Avatar] Offline
I identified some errors.

On page 19, I wrote "open the Git GUI tool and select Create New Repository." This should be "open the Git GUI tool and select Clone Existing Repository."

On page 19, I wrote "Click in the Clone Existing Repository text box, and type the source URL..." This should be "In the dialog box, after pressing Clone Existing Repository, type the source URL...".

This was found per the discussion thread here:
Kunio (24) [Avatar] Offline
Errata: SHA1 ID in page 325
On page 325, 19.2.4 History View, at the end of the last paragraph of TRY IT NOW, it says "after selecting the second commit (for SHA1 ID 2628aff4)".
But the SHA1 ID should be f3569d7d just as shown in the Figures 19.37 and 19.38.
Kunio (24) [Avatar] Offline
Errata: page 337 missing command name
On page 337, 20.3 Configuring Git's default editor, TRY IT NOW (WINDOWS), near the bottom of the page, it says:

git -c core.editor=notepad++ --local --edit

but the line should include the "config" command, as the Figure 20.10 shows in the command line, as:

git -c core.editor=notepad++ config --local --edit
Kunio (24) [Avatar] Offline
Errata: p.328 chapter reference
On page 328, 20 Sharpening your Git, near the end of the first paragraph, it says: "You've also used git config to create aliases (chapter 15)."
But the git config command to create an alias was introduced in Above and Beyond section in Chapter 9 (page 126), not Chapter 15.

- I think this will be the last one from Kunio the translator.
Susan Harkins (402) [Avatar] Offline
You can find the current errata list at Thanks!

Susan Harkins
Errata Editor
Manning Publications
ravenhunter (23) [Avatar] Offline
Susan Harkins wrote:You can find the current errata list at Thanks!

Susan Harkins
Errata Editor
Manning Publications

I get an access denied document when I try to go to that link.
Susan Harkins (402) [Avatar] Offline
Please try again -- it's working now. Thank you!

Susan Harkins
Errata Editor
ravenhunter (23) [Avatar] Offline
I'm still getting the same error message.
Susan Harkins (402) [Avatar] Offline
214736 (6) [Avatar] Offline
Errata are NOT fixed in eBook versions (2017-March-20)
Given the topic of this book, I think it reasonable to presume the author has revised his source to accommodate each reported-and-confirmed erratum. Based upon favorable reviews, I just purchased the eBook versions (pdf, epub, mobi). I am very disappointed to discover these eBooks have not incorporated such revisions. (On the other hand, I would not expect printed copies to become up-to-date until the next press-run.)
214736 (6) [Avatar] Offline
p31 refers to missing stuff
Second paragraph on page 31 of PDF states "I also have some videos on that demonstrate some of these techniques." As of 2017-March-20, no such videos can be found at --- perhaps this is the result of publisher actions which were beyond the author's influence. In any event, this should be added to the official list of errata.

Note: logistics of printing mean readers of a paper book must rely on the errata list. On the other hand, some other publishers of eBooks do strive to keep those versions updated !
rickumali (130) [Avatar] Offline
p31 refers to missing stuff
Hello! I'm the author, and I wanted to thank you for posting here on the forums.

214736 wrote: Second paragraph on page 31 of PDF states "I also have some videos on that demonstrate some of these techniques." As of 2017-March-20, no such videos can be found ...

This is entirely my fault. I never provided videos to the publisher. Given your interest, I'll spin up a quick video that shows off the techniques described in the section. I'll post the link here, and in a separate forum post, and on MoreLunches. This oversight should have been mentioned in the errata, but I hope to correct it within the week. Thank you for your patience!
214736 (6) [Avatar] Offline
Command-line editing, discussed on pp 30-31, using standard (Emacs) commands should be familiar to many folk. My reference to p31 as citing missing videos was merely using the first occasion I noticed. See below for a better place to augment existing prose.

While I think "committing parts of changes" at the hunk-level is a moderately advanced topic which should have been deferred after day-17, command-line versions for day-7 could benefit from a narrated video (as mentioned on p 93). Note: I suggest the presentation be editor-agnostic (vi, nano, emacs, ...) with emphasis on implementing the cryptic clues presented by git-editor.
214736 (6) [Avatar] Offline
listing 9.1 (pp 125-6)
Listing 9.1 (pp 125-6 of PDF) is too plain to have been produced by the "lol" command shown prior to it: no 2D display of branching, no coloring.

Figure 9.11 (p 125) would be improved if it showed a 2D graph of the branching.
rickumali (130) [Avatar] Offline
I created my first video supplement, for section 7.4.3 ("Committing parts of a file by using Git GUI"). I have a few more supplements in queue now. Look for these announcements in the separate forum posts.

The YouTube URL is:

438541 (2) [Avatar] Offline
In section 2.2.3, I believe that the last sentence of the first paragraph should state "Debugging statements, sensitive information such as passwords, and other items for the developer’s eyes only can be cleanly removed by using the staging area" instead of "Debugging statements, sensitive information such as passwords, and other items for the developer’s eyes can be cleanly removed only by using the staging area." In summary, the word "only" appears to be in the wrong place.
59561 (1) [Avatar] Offline
Page 155: the last line on the page 'git commit -m “Committing bar.”' uses smart quotes, rather than regular double quotes. BASH does not recognize smart quotes and produces the following message 'error: pathspec 'bar.”' did not match any file(s) known to git.'.

Replacing smart quotes with regular double quotes resolved the issue.