ivan.arrizabalaga (2) [Avatar] Offline
#1
Hi, in chapter 5 I cannot manage to download hightcharts dependencies since I find this error:

chapter5$ ionic add highcharts-release#4.0.4 highcharts-ng#0.0.7


Failed to find the bower component "highcharts-release#4.0.4".
Are you sure it exists? (CLI v1.5.5)

Your system information:

Cordova CLI: 5.0.0
Ionic Version: 1.0.0
Ionic CLI Version: 1.5.5
Ionic App Lib Version: 0.2.2
OS: Distributor ID:	Ubuntu Description:	Ubuntu 14.04.2 LTS 
Node Version: v0.10.37



Whats wrong?
Thanks in advance.
ivan.arrizabalaga (2) [Avatar] Offline
#2
I will autoreply, smilie.

Since Ionic uses bower behind the curtains I must install bower manually before starting to use the ionic add command.

sudo npm install -g bower
ionic add highcharts-release#4.0.4 highcharts-ng#0.0.7


jeremy.wilken (208) [Avatar] Offline
#3
Sorry I've had some trouble getting my login working while on the road a lot the last few weeks!

Yes, Bower is part of the toolchain and I hadn't noticed it doesn't error properly when Bower isn't installed. I should see if I can get a note about this into the book, though Ionic CLI should do better to fail without Bower here with info. Someone opened a bug recently https://github.com/driftyco/ionic-cli/issues/458.