The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

252991 (4) [Avatar] Offline
#1
In section 1.2.1, you use the term measurement to specify attributes of the instance and in the table that immediately follows you use the term features.

From a consistency point of view I think it would be better to use one term in both places, what do you think?

Also would attribute be a better word than measurement?

Even from an programming point of view, chances are that an instance might be modelled as an object and given objects have attributes it might be easier to connect the dots for programmers reading this book, who might be the main audience of this book.

Thanks.
henrik.brink (22) [Avatar] Offline
#2
Hi there, thanks for your feedback!

You are bringing up a very good point. In fact, throughout the ML space there are many names for the input .... well, features. I think "features" may be the most common, so that is what we try to use and we should make sure to normalize it throughout the book.

Some others are Variable, Measurement, Column, etc, as you've noticed. I understand your point about "attribute", but I have rarely heard it used for the input features in ML systems. It may be confusing as we sometimes use it for the parameters/attributes of the model, i.e. the number of trees in a random forest etc.

Hope that makes sense, otherwise don't hesitate to respond here. And, by any means please bring up any other points you may have!

- Henrik