The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

michael.l.schneider@gmail.com (2) [Avatar] Offline
#1
I have downloaded the latest vagrant, virtualbox, and chefdk

when I run vagrant up primary, the following errror is output

-------------------------------------------
D:\Scratch\rmqid-vagrant>vagrant destroy  primary
    primary: The Berkshelf shelf is at "U:/.berkshelf/vagrant-berkshelf/shelves/berkshelf20150203-11332-fjs7mn-primary"
==> primary: Sharing cookbooks with VM
==> primary: Running cleanup tasks for 'berkshelf'...
    primary: Are you sure you want to destroy the 'primary' VM? [y/N] y
==> primary: Forcing shutdown of VM...
==> primary: Destroying VM and associated drives...
==> primary: Running cleanup tasks for 'chef_solo' provisioner...

D:\Scratch\rmqid-vagrant>vagrant up  primary
Bringing machine 'primary' up with 'virtualbox' provider...
    primary: The Berkshelf shelf is at "U:/.berkshelf/vagrant-berkshelf/shelves/berkshelf20150203-3808-1v39nhp-primary"
==> primary: Sharing cookbooks with VM
==> primary: Importing base box 'rabbitmq-in-depth'...
==> primary: Matching MAC address for NAT networking...
==> primary: Setting the name of the VM: rmqid-vagrant_primary_1422971452220_72348
==> primary: Fixed port collision for 22 => 2222. Now on port 2200.
==> primary: Clearing any previously set network interfaces...
==> primary: Preparing network interfaces based on configuration...
    primary: Adapter 1: nat
    primary: Adapter 2: hostonly
==> primary: Forwarding ports...
    primary: 1883 => 1883 (adapter 1)
    primary: 5671 => 5671 (adapter 1)
    primary: 5672 => 5672 (adapter 1)
    primary: 8883 => 8883 (adapter 1)
    primary: 8888 => 8888 (adapter 1)
    primary: 8900 => 8900 (adapter 1)
    primary: 9001 => 9001 (adapter 1)
    primary: 15670 => 15670 (adapter 1)
    primary: 15671 => 15671 (adapter 1)
    primary: 15672 => 15672 (adapter 1)
    primary: 61613 => 61613 (adapter 1)
    primary: 22 => 2200 (adapter 1)
==> primary: Booting VM...
==> primary: Waiting for machine to boot. This may take a few minutes...
    primary: SSH address: 127.0.0.1:2200
    primary: SSH username: vagrant
    primary: SSH auth method: private key
    primary: Warning: Remote connection disconnect. Retrying...
    primary:
    primary: Vagrant insecure key detected. Vagrant will automatically replace
    primary: this with a newly generated keypair for better security.
    primary:
    primary: Inserting generated public key within guest...
    primary: Removing insecure key from the guest if its present...
    primary: Key inserted! Disconnecting and reconnecting using new SSH key...
==> primary: Machine booted and ready!
==> primary: Checking for guest additions in VM...
==> primary: Setting hostname...
==> primary: Configuring and enabling network interfaces...
==> primary: Mounting shared folders...
    primary: /vagrant => D:/Scratch/rmqid-vagrant
    primary: /tmp/vagrant-chef/968ba7cce766185f9f92dd75693c6f60/cookbooks => U:/.berkshelf/vagrant-berkshelf/shelves/berkshelf20150203-3808-1v39nhp-primary
==> primary: Running provisioner: chef_solo...
==> primary: Detected Chef (latest) is already installed
Generating chef JSON and uploading...
==> primary: Running chef-solo...
==> primary: [2015-02-03T13:51:30+00:00] INFO: Forking chef instance to converge...
==> primary: [2015-02-03T13:51:30+00:00] INFO: *** Chef 11.8.0 ***
==> primary: [2015-02-03T13:51:30+00:00] INFO: Chef-client pid: 2034
==> primary: [2015-02-03T13:51:30+00:00] INFO: Setting the run_list to ["recipe[rabbitmq::default]", "recipe[rabbitmq::mgmt_console]", "recipe[rabbitmq::plugin_management]", "re
cipe[supervisor::default]", "recipe[zeromq::default]", "recipe[rabbitmq-in-depth::default]", "recipe[rabbitmq-in-depth::gitrepo]", "recipe[rabbitmq-in-depth::ipython]", "recipe[
rabbitmq-in-depth::opencv]", "recipe[rabbitmq-in-depth::rabbitmq]", "recipe[rabbitmq-in-depth::statelessd]"] from JSON
==> primary: [2015-02-03T13:51:30+00:00] INFO: Run List is [recipe[rabbitmq::default], recipe[rabbitmq::mgmt_console], recipe[rabbitmq::plugin_management], recipe[supervisor::de
fault], recipe[zeromq::default], recipe[rabbitmq-in-depth::default], recipe[rabbitmq-in-depth::gitrepo], recipe[rabbitmq-in-depth::ipython], recipe[rabbitmq-in-depth::opencv], r
ecipe[rabbitmq-in-depth::rabbitmq], recipe[rabbitmq-in-depth::statelessd]]
==> primary: [2015-02-03T13:51:30+00:00] INFO: Run List expands to [rabbitmq::default, rabbitmq::mgmt_console, rabbitmq::plugin_management, supervisor::default, zeromq::default,
 rabbitmq-in-depth::default, rabbitmq-in-depth::gitrepo, rabbitmq-in-depth::ipython, rabbitmq-in-depth::opencv, rabbitmq-in-depth::rabbitmq, rabbitmq-in-depth::statelessd]
==> primary: [2015-02-03T13:51:30+00:00] INFO: Starting Chef Run for primary
==> primary: [2015-02-03T13:51:30+00:00] INFO: Running start handlers
==> primary: [2015-02-03T13:51:30+00:00] INFO: Start handlers complete.
==> primary: [2015-02-03T13:51:30+00:00] ERROR: Running exception handlers
==> primary: [2015-02-03T13:51:30+00:00] ERROR: Exception handlers complete
==> primary: [2015-02-03T13:51:30+00:00] FATAL: Stacktrace dumped to /var/chef/cache/chef-stacktrace.out
==> primary: [2015-02-03T13:51:30+00:00] ERROR: Cookbook rabbitmq not found. If you're loading rabbitmq from another cookbook, make sure you configure the dependency in your met
adata
==> primary: [2015-02-03T13:51:30+00:00] INFO: Forking chef instance to converge...
==> primary: [2015-02-03T13:51:30+00:00] FATAL: Chef::Exceptions::ChildConvergeError: Chef run process exited unsuccessfully (exit code 1)
Chef never successfully completed! Any errors should be visible in the
output above. Please fix your recipes so that they properly complete.

D:\Scratch\rmqid-vagrant>





Here is the output from the vm instance logs for chef
vagrant@primary:/var/chef/cache$ cat chef-stacktrace.out
Generated at 2015-02-03 13:51:30 +0000
Chef::Exceptions::CookbookNotFound: Cookbook rabbitmq not found. If you're loading rabbitmq from another cookbook, make sure you configure the dependency in your metadata
/opt/chef/embedded/lib/ruby/gems/1.9.1/gems/chef-11.8.0/lib/chef/cookbook/cookbook_collection.rb:38:in `block in initialize'
/opt/chef/embedded/lib/ruby/gems/1.9.1/gems/ohai-6.20.0/lib/ohai/mash.rb:77:in `yield'
/opt/chef/embedded/lib/ruby/gems/1.9.1/gems/ohai-6.20.0/lib/ohai/mash.rb:77:in `default'
/opt/chef/embedded/lib/ruby/gems/1.9.1/gems/ohai-6.20.0/lib/ohai/mash.rb:77:in `default'
/opt/chef/embedded/lib/ruby/gems/1.9.1/gems/chef-11.8.0/lib/chef/run_context/cookbook_compiler.rb:265:in `[]'
/opt/chef/embedded/lib/ruby/gems/1.9.1/gems/chef-11.8.0/lib/chef/run_context/cookbook_compiler.rb:265:in `each_cookbook_dep'
/opt/chef/embedded/lib/ruby/gems/1.9.1/gems/chef-11.8.0/lib/chef/run_context/cookbook_compiler.rb:243:in `add_cookbook_with_deps'
/opt/chef/embedded/lib/ruby/gems/1.9.1/gems/chef-11.8.0/lib/chef/run_context/cookbook_compiler.rb:87:in `block in cookbook_order'
/opt/chef/embedded/lib/ruby/gems/1.9.1/gems/chef-11.8.0/lib/chef/run_context/cookbook_compiler.rb:85:in `each'
/opt/chef/embedded/lib/ruby/gems/1.9.1/gems/chef-11.8.0/lib/chef/run_context/cookbook_compiler.rb:85:in `cookbook_order'
/opt/chef/embedded/lib/ruby/gems/1.9.1/gems/chef-11.8.0/lib/chef/run_context/cookbook_compiler.rb:97:in `compile_libraries'
/opt/chef/embedded/lib/ruby/gems/1.9.1/gems/chef-11.8.0/lib/chef/run_context/cookbook_compiler.rb:70:in `compile'
/opt/chef/embedded/lib/ruby/gems/1.9.1/gems/chef-11.8.0/lib/chef/run_context.rb:86:in `load'
/opt/chef/embedded/lib/ruby/gems/1.9.1/gems/chef-11.8.0/lib/chef/client.rb:250:in `setup_run_context'
/opt/chef/embedded/lib/ruby/gems/1.9.1/gems/chef-11.8.0/lib/chef/client.rb:498:in `do_run'
/opt/chef/embedded/lib/ruby/gems/1.9.1/gems/chef-11.8.0/lib/chef/client.rb:199:in `block in run'
/opt/chef/embedded/lib/ruby/gems/1.9.1/gems/chef-11.8.0/lib/chef/client.rb:193:in `fork'
/opt/chef/embedded/lib/ruby/gems/1.9.1/gems/chef-11.8.0/lib/chef/client.rb:193:in `run'
/opt/chef/embedded/lib/ruby/gems/1.9.1/gems/chef-11.8.0/lib/chef/application.rb:208:in `run_chef_client'
/opt/chef/embedded/lib/ruby/gems/1.9.1/gems/chef-11.8.0/lib/chef/application/solo.rb:221:in `block in run_application'
/opt/chef/embedded/lib/ruby/gems/1.9.1/gems/chef-11.8.0/lib/chef/application/solo.rb:213:in `loop'
/opt/chef/embedded/lib/ruby/gems/1.9.1/gems/chef-11.8.0/lib/chef/application/solo.rb:213:in `run_application'
/opt/chef/embedded/lib/ruby/gems/1.9.1/gems/chef-11.8.0/lib/chef/application.rb:66:in `run'
/opt/chef/embedded/lib/ruby/gems/1.9.1/gems/chef-11.8.0/bin/chef-solo:25:in `<top (required)>'
/usr/bin/chef-solo:23:in `load'
/usr/bin/chef-solo:23:in `<main>'vagrant@primary:/var/chef/cache$

----------------------------------------------------------------------------------------------------------------------------------------------------------------
gavinmroy (15) [Avatar] Offline
#2
Sorry for the problem. Please make sure you grab the latest Vagrantfile from https://gavinroy.com/download/rabbitmq-in-depth/rmqid-vagrant.zip and let me know how it works for you.
nachbar (45) [Avatar] Offline
#3
I cannot download the .zip file - after I get past the Certificate errors, I get this response, which suggests a permissions problem:

<Error>
<Code>AccessDenied</Code>
<Message>Access Denied</Message>
<RequestId>3E62DFB1AE95EA41</RequestId>
<HostId>
YOkzvMwUyzMzUTQolmQgVqJXqAQCspnMUtR/aXRRRJ8padPVK7Hv8c7GG59dOQgYX1OErMdnR9U=
</HostId>
</Error>

Using the scripts on the github and vagrant up primary, I get a long error output, apparently because of a problem with authenticating the RabbitMQ package.

The first error is:

==> primary: GPG error: http://www.rabbitmq.com testing InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6B73A36E6026DFCA

Then:

==> primary: WARNING: The following packages cannot be authenticated!
==> primary: rabbitmq-server
==> primary: E
==> primary: :
==> primary: There are problems and -y was used without --force-yes

I would be happy to post the entire message if that would help.

Thanks!
wxlund (25) [Avatar] Offline
#4
gavinmroy wrote:Sorry for the problem. Please make sure you grab the latest Vagrantfile from https://gavinroy.com/download/rabbitmq-in-depth/rmqid-vagrant.zip and let me know how it works for you.


I just tried to download from your URL and got the same error:

wget https://gavinroy.com/download/rabbitmq-in-depth/rmqid-vagrant.zip
--2017-10-06 15:29:26-- https://gavinroy.com/download/rabbitmq-in-depth/rmqid-vagrant.zip
Resolving gavinroy.com... 52.85.83.177, 52.85.83.213, 52.85.83.147, ...
Connecting to gavinroy.com|52.85.83.177|:443... connected.
HTTP request sent, awaiting response... 403 Forbidden
2017-10-06 15:29:28 ERROR 403: Forbidden.

The reason I was checking again was I installed it sometime back and was curious if you were using a newer version of RabbitMQ for the final edition of the book. btw - great book!