lucatros (9) [Avatar] Offline
Wouldn't it be better to use "house" or "houses" instead of "houseNameId" for the helper name? I mean, if the there are more attributes it wouldn't make sense to use "houseNameIdAddressCityZip".

Let me know if I'm being too picky on commenting on this kind of stuff and I'll just post on mayor issues.

On the other hand, is there any difference on "return HousesCollection.find()" VS "return HousesCollection.find({}, {});"?

Edit: I spoke too soon. I see the helper's name makes sense on listing 4-9.
stephan.hochhaus (92) [Avatar] Offline
Glad you found it was a useful name smilie
stephan.hochhaus (92) [Avatar] Offline
The new helper name is now
to indicate it holds a variety of houses and their name and Id attributes. Plus a footnote explains that it will become more efficient a bit later in the chapter smilie