gary_lucas (19) [Avatar] Offline
#1
This is after neutering the pip install script, however I don't think these would be related.



2014-06-22 23:59:38.640 | Starting new HTTP connection (1): 192.168.1.30
2014-06-22 23:59:38.778 | Starting new HTTP connection (1): 192.168.1.30
2014-06-22 23:59:38.815 | Starting new HTTP connection (1): 192.168.1.30
2014-06-22 23:59:38.855 | + public_net_id=
2014-06-22 23:59:38.855 | + neutron-debug --os-tenant-name admin --os-username admin --os-password devstack probe-create --device-owner compute
2014-06-22 23:59:39.346 | Starting new HTTP connection (1): 192.168.1.30
2014-06-22 23:59:39.489 | usage: neutron-debug probe-create [-h] [--request-format {json,xml}]
2014-06-22 23:59:39.489 | [--device-owner {network,compute}]
2014-06-22 23:59:39.489 | network_id
2014-06-22 23:59:39.489 | neutron-debug probe-create: error: too few arguments
2014-06-22 23:59:39.524 | + exit_trap
2014-06-22 23:59:39.524 | + local r=2
2014-06-22 23:59:39.525 | ++ jobs -p
2014-06-22 23:59:39.525 | + jobs=
2014-06-22 23:59:39.525 | + [[ -n '' ]]
2014-06-22 23:59:39.525 | + exit 2

Pretty much a copy of the book local.config. Happy to provide any other logs if it may help.
echeadle (87) [Avatar] Offline
#2
Re: Neutron-debug ... bug
I had problems with neutron running on RHEL 6. If I remember correctly the localrc in the book had several network settings. I used only the HOST_IP address and I was able to get neutron to work.

Here is what i put in my post.

HOST_IP=10.22.40.32
#Changed 5/23/2014 I removed the following three lines
#FLOATING_RANGE=192.168.1.0/24
#PUBLIC_NETWORK_GATEWAY=192.168.1.1
#FIXED_RANGE=10.0.0.0/24

Message was edited by:
echeadle