winsonkwok (7) [Avatar] Offline
#1
Based on the reason given in p23, the issueInvoice function should become:

boolean issueInvoice(Invoice i) { ... }

and then

// if issue invoice okay, get the customer balance
if (customer.issueInvoice(invoice)) {
customer.getBalance()
}