echeadle (87) [Avatar] Offline
#1
I ran stack.sh and started up devstack. Worked in it a bit and realized that I could not connect to the outside world. I believe I have to set, In local.conf, the FLOATING_RANGE and the PUBLIC_GATEWAY to values that are part of the host computer's ip network. So I made the changes and the system continued to not start up devstack. I tried unstack.sh and clean.sh. I then tried unstack.sh then clean.sh and resetting iptables. I was able to get devstack working again.
cody.bumgardner (57) [Avatar] Offline
#2
Re: Changed local.conf and stack.sh failed.
Hi echeadle,

I didn't do a good job of explaining these things in the text, but this will be corrected.

HOST_IP=10.163.200.32 //This is my physical adapter address on eth0

FLOATING_RANGE=192.168.1.0/24 //This is a dummy address that will work regardless of network. It is an internal address that is made to work like a real public address. I had to do this so that the examples didn't require two interfaces. This is also the reason we have to create a NAT rule to allow traffic to pass.

PUBLIC_NETWORK_GATEWAY=192.168.1.1 //This references our dummy public range and can be used on any physical network.

FIXED_RANGE=10.0.0.0/24 //This is the internal network to be used for VMs and can be used on any network.


Basically, the only network that needs to be specific to your physical server and network is the HOST_IP.

Sorry for the confusion.

Cody