NathanH (4) [Avatar] Offline
#1
Thought I would give you some quick info. It looks like things are currently kinda broken for 14.04. I ran into the following issues:


This one has a work around,

https://bugs.launchpad.net/devstack/+bug/1316328

But even after that I ran into issues with networking, specifically adding the router gateway. I got a SIOCADDRT: Network is unreachable error. The same config file worked correctly on 12.04, though I did run into issues with the tempest client. I had to disable that in the config. It sounds like another known issue with a python update.

https://bugs.launchpad.net/subunit/+bug/1274056

Might have some time to dig into it more later, but at least now I'm getting successes on the exercise!
cody.bumgardner (57) [Avatar] Offline
#2
Re: Ubuntu 14.04
Thanks for the info!

I had gone back and forth on using 12.04/13.04/14.04 and settled on 12.04 since many would use that in production if they used Ubuntu.

While the book is in review I am rebuilding a large multi-node lab, while I work on part 2. This will free up the nodes I was using for devstack, which is currently hard enough to get to work with 12.04 smilie

I will fire up 14.04 node and based on your info see if I can get a working config. I think it might be useful if I can have both working configs and scripts for several versions and distributions.

This being said, even the stable version of DevStack and change form data to day and is not guaranteed to always work. Luckily, this is much less of a problem in production.

Thanks for the info!
Cody
cody.bumgardner (57) [Avatar] Offline
#3
Re: Ubuntu 14.04
NathanH,

Problems still exist with Ubuntu 14.04 and DevStack.

http://www.manning-sandbox.com/thread.jspa?threadID=70294&tstart=0

With any luck this will be resolved soon.

Thanks,
Cody