rpolunsky (5) [Avatar] Offline
#1
I downloaded and installed activiti 5.10. However, when I took the code for Listing 1.4 and attempted to run it, I found that Maven had directed all of the references to version 5.11. That caused the following error:

org.activiti.engine.ActivitiWrongDbException: version mismatch: activiti library version is '5.11', db version is 5.10 Hint: Set <property name="databaseSchemaUpdate" to value="true" or value="create-drop" (use create-drop for testing only!) in bean processEngineConfiguration in activiti.cfg.xml for automatic schema creation >

How do I force Maven to fetch 5.10 references?

RESOLVED: The pom.xml file from the sample code referenced 5.11; I changed that to 5.10 and told Maven to refresh, and it pulled correct references.

Message was edited by:
rpolunsky