The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

ahmed360 (3) [Avatar] Offline
#1
Hi,

I followed the instructions in Chapter 10 for exposing remote services. This is the first part where I pointed my browser to the published URL on port 9000 as indicated in the book. I get a dns error.

Now, as mentioned in that chapter, I'm not using localhost, instead I'm using the actual IP address obtained from ifconfig (I'm running on a mac). I know that the IP is correct since it works just fine for the fastfood web app that we developed early in the book, which runs on port 8080.

Everything looks fine, the foreign foods bundle is in ACTIVE state and there are no issues what-so-ever.

I'm kind of lost at this point. Any pointers on what should I do to debug this problem further?

Can I change the blueprint default 9000 port to see if it will work on another port?

Thank you.
ahmed360 (3) [Avatar] Offline
#2
Re: Unable to access remote services
I'm hoping to get any insight on this issue as it has not been resolved and I'm running out of ideas.

Here's a snippet of the output of "bundle" command that I ran on the pax web jetty bundle to identify the current port. As you can see, it indicates that the port is 8080. However, when I point the browser there to get the wsdl or to execute the web service, I get a DNS error: server not found.

========

osgi> bundle 7
org.ops4j.pax.web.pax-web-jetty-bundle_0.8.1 [7]
Id=7, Status=ACTIVE Data Root=/Users/me/src/technology/OSGi/EnterpriseOSGiInAction/samples-1.0.0/blog/blog-assembly/target/configuration/org.eclipse.osgi/bundles/7/data
Registered Services
{org.ops4j.pax.web.service.spi.ServerControllerFactory}={service.id=32}
{org.osgi.service.cm.ManagedService}={service.pid=org.ops4j.pax.web, service.id=33}
{org.osgi.service.http.HttpService, org.ops4j.pax.web.service.WebContainer}={org.ops4j.pax.web.ssl.keystore=/Users/ahkhatta/.keystore, org.osgi.service.http.port.secure=8443, org.ops4j.pax.web.listening.addresses=, org.osgi.service.http.port=8080, org.ops4j.pax.web.ssl.clientauthneeded=false, org.osgi.service.http.useNIO=true, org.osgi.service.http.enabled=true, org.osgi.service.http.secure.enabled=true, org.ops4j.pax.web.ssl.clientauthwanted=false, javax.servlet.context.tempdir=/private/var/folders/nf/15lpcysz2cjfdq7hbz9d_qgr0000gn/T/.paxweb7097328779641714211, service.id=41}
Services in use:
{org.ops4j.pax.web.service.spi.ServerControllerFactory}={service.id=32}
Exported packages
org.ops4j.pax.web.service; version="0.8.1"[exported]
. . .

Message was edited by:
ahmed360