The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

mcaudy (8) [Avatar] Offline
#1
Not sure if I should post this on the Callimachus group instead, but since Chapter 9 of the Linked Data book MEAP is on Callimachus, I am posting it here.

I installed Callimachus 1.0 and it was running fine on my Macbook Pro (OS 10.7.5). The features described in the book and in the Callimachus online docs all seemed to be working.

However, as I was trying to install the demos, in particular directory-1.3.car, something went wrong and it appears that some of the files that were created previously were deleted and Callimachus no longer runs, although most of the 1.0 directories are still there, as well as all of the bin/ files, etc. One thins that was now missing (based on my memory) was the repositories/callimachus/caches/, directory that contained my home page, and the sample RDF I had created.

I have tried to get things working again by deleting and re-installing 1.0. This appears to work, and the terminal says that the server is running at http://localhost:8080, but the server is not actually running at that URL.

I also tried running the bin/callimachus-uninstall.sh, but I get a "This program is not installed" message, even though the file is in the bin directory.

I also tried re-running the setup.sh but this did not solve the problem.

I even tried installing callimachus 1.0.1, but I also could not get the server working there.

Please advise. I am keen to start using RDF in my genomics research, and Callimachus looks like a great tool for integrating RDF.

Thank you.
mcaudy (8) [Avatar] Offline
#2
Re: Problem with Callimachus
I have now successfully installed Callimachus 1.0.1 on my Ubuntu 11.04 dev system (running on VMware Fusion on my Macbook Pro).

This is my preferred dev environment. I am a genomics researcher who has used Mac OS X for Linux development up through 10.6, at which point I switched to Linux development on Ubuntu.

I therefore do not need help getting Callimachus to run on Mac 10.7. I will be happy to help try to trouble shoot and fix any problems on the Mac, if I can be of help, but I plan to stick with Ubuntu now.
david.wood (45) [Avatar] Offline
#3
Re: Problem with Callimachus
Hi mcaudy,

Several of us use Macs as our primary development machines, so I can assure you that Callimachus works on Macs. However, I don't have enough information to help you troubleshoot your particular question.

It would appear (but I might be wrong) that you installed the directory sample app into the base Callimachus folder instead of creating a new folder to hold it. Could that be it? If so, that would certainly screw up a Callimachus installation mightily. Callimachus 1.1 is about to be released, which keeps you from doing that.

The bin/callimachus-install.sh script should only be run on Linux and creates the daemon start/stop scripts used by Unix runlevels. The install/uninstall scripts do not apply to Mac OS X. This is described in the README.txt.

We would like to help you be successful with Callimachus. For future support requests, please send email to callimachus-discuss@googlegroups.com and, if you have trashed your system, please send the file log/callimachus.0.log with your message, along with any other information like the OS version.

Regards,
Dave