The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

johnm149 (2) [Avatar] Offline
#1
I am using your testpage.aspx and its not working - can you tell me whats wrong with it

<html>
Server Information
#A
------------------

Server Name = <%= Request.ServerVariables("SERVER_NAME") %>
#B
Server Protocol = <%= Request.ServerVariables("SERVER_PROTOCOL") %>

Server IP = <%= Request.ServerVariables("LOCAL_ADDR") %>

Server Port = <%= Request.ServerVariables("SERVER_PORT") %>

IIS Version = <%= Request.ServerVariables("SERVER_SOFTWARE") %>



Website Information

------------------

Application Physical Path = <%= <br /> Request.ServerVariables("APPL_PHYSICAL_PATH"smilie %>
#C
Application Path = <%= Request.ServerVariables("PATH_INFO") %>

Application Translated Path = <%= <br /> Request.ServerVariables("PATH_TRANSLATED"smilie %>



</html>
jason.helmick (63) [Avatar] Offline
#2
Re: testpage.aspx not working - Month of lunches IIS
Hey John!

Try adding the component Web-ASP...that should fix it.

Thanks for pointing this out...The new version of .net creates some issues that I'm trying to correct for in the script.........

Cheers!

Jason
johnm149 (2) [Avatar] Offline
#3
Re: testpage.aspx not working - Month of lunches IIS
Thanks, Jason - I got it to work
dsolodow (7) [Avatar] Offline
#4
Re: testpage.aspx not working - Month of lunches IIS
One thing I discovered on this if using Server 2012; the component to install is web-asp-net45.

Web-asp-net installs asp.net 3.5 which allows app-pools using .net framework 2.0, but on IIS8 the app pools default to .net 4.0 which needs web-asp-net45.
jason.helmick (63) [Avatar] Offline
#5
Re: testpage.aspx not working - Month of lunches IIS
Thank you!

Yes I have made the correction as I ran into this too....Again thank you for the help!