The Author Online Book Forums are Moving

The Author Online Book Forums will soon redirect to Manning's liveBook and liveVideo. All book forum content will migrate to liveBook's discussion forum and all video forum content will migrate to liveVideo. Log in to liveBook or liveVideo with your Manning credentials to join the discussion!

Thank you for your engagement in the AoF over the years! We look forward to offering you a more enhanced forum experience.

rlegorreta (2) [Avatar] Offline
#1
I had problem and could not run examples of chapter2 and chapter4.

- For test units: The test has a compliance with port number from cassandra, so I have to shutdown the cassandra server first.
- I believe there is a code error. The test unit WSServiceTest line 34 wants a bean helloClient, is should be accountClient.
- The test unit RestServiceTest generates a json error because it is malformed.

- It compiles but generates errors when executed. The class Chapter2Launcher (no class CXFBasedJettyLauncher) has a reference to a file  cxf-extension-soap.xml. This file does not exist in the project, neither in its dependencies.

- I tried from the command line, but the protect plugin is not well configured to run. It seem the class name is also wrong.

Need help to know what I am doing wrong.
rlegorreta (2) [Avatar] Offline
#2
Re: Can run examples for chapter2
Does anybody check this thread????

Is there somebody that ran source code from chapter two recently? The code does not run and it is different from the book.
lollisoft (4) [Avatar] Offline
#3
Re: Can run examples for chapter2
Hi,

I had the same issues, but I got the tests run by commenting them and then again uncomment.

I validated testInvalidMessage by asserting
assertEquals(501, client.executeMethod(method)); instead of 500 an I got a failure. I don't know how this fails without modified code.

What I tried was to run the REST service alone from within traffic-service-remoting-REST.
(mvn exec:java)

So my question is how to get rid of the following error:

stsmac:traffic-service-remoting-REST lothar$ mvn exec:java
[INFO] Scanning for projects...
[WARNING]
[WARNING] Some problems were encountered while building the effective model for org.manning.ossoagov.chapter2:traffic-service-remoting-REST:jar:0.0.1-SNAPSHOT
[WARNING] 'build.plugins.plugin.version' for org.apache.maven.plugins:maven-compiler-plugin is missing. @ org.manning.ossoagov.chapter2:chapter2-parent:0.0.1-SNAPSHOT, /Users/lothar/develop/Projects/ReferenzProjekte/WSO2SOAArchitecture/workspace/chapter2/pom.xml, line 21, column 12
[WARNING]
[WARNING] It is highly recommended to fix these problems because they threaten the stability of your build.
[WARNING]
[WARNING] For this reason, future Maven versions might no longer support building such malformed projects.
[WARNING]
[INFO]
[INFO] ------------------------------------------------------------------------
[INFO] Building Traffic Service REST Remoting 0.0.1-SNAPSHOT
[INFO] ------------------------------------------------------------------------
[INFO]
[INFO] >>> exec-maven-plugin:1.2.1:java (default-cli) @ traffic-service-remoting-REST >>>
[INFO]
[INFO] <<< exec-maven-plugin:1.2.1:java (default-cli) @ traffic-service-remoting-REST <<<
[WARNING] The POM for org.manning.ossoagov.chapter2:traffic-service-general:jar:0.0.1-SNAPSHOT is missing, no dependency information available
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 2.111s
[INFO] Finished at: Tue Feb 12 06:37:44 CET 2013
[INFO] Final Memory: 5M/81M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project traffic-service-remoting-REST: Could not resolve dependencies for project org.manning.ossoagov.chapter2:traffic-service-remoting-REST:jar:0.0.1-SNAPSHOT: Could not find artifact org.manning.ossoagov.chapter2:traffic-service-general:jar:0.0.1-SNAPSHOT -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException
stsmac:traffic-service-remoting-REST lothar$